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In “The Power of Preview: Cropping and Resizing 
Images” (18 March 2016) and “The Power of Preview: 

Annotating Documents and Images” (2 April 2016), we 
explored editing and annotation tasks with Preview, OS 
X’s built-in document and image powerhouse. This week, 
we’ll go deeper with some advanced editing techniques, 
and double back for a few tidbits we skipped in previous 
articles.

Advanced Selection Tools for Images — In “The 
Power of Preview: Cropping and Resizing Images,” we 
discussed using the Rectangular Selection tool. However, 
when working with images, several other selection tools 
offer more variety and control. You find them in the Mark-
up Toolbar, which you display by choosing View > Show 
Markup Toolbar (Command-Shift-A). The selection tools 
are accessed via the first button at the left.

by Adam C. Engst and Josh Centers 

The Power of Preview:
Advanced Editing Techniques

Elliptical Selection is the second choice on the selection 
tools pop-up menu. It works just like the Rectangular 
Selection tool, except that it selects elliptical rather than 
rectangular areas. As with the Rectangular Selection tool 
and the shape tools, you can press Option while making 
the original selection to size it from the center, and pressing 
Shift gives you a perfect circle.

After dragging out an elliptical selection, you get the usual 
drag handles. The handles attached to the selection ellipse 
itself adjust one dimension at a time, whereas those on the 
corners of the rectangle that encloses the ellipse can adjust 
two dimensions at once.

The next selection tool is Lasso Selection, which Bill Atkinson 
first invented for MacPaint in 1983. The Rectangular 
Selection and Elliptical Selection tools fall down when you 
need to select an irregularly shaped object or portion of a 
graphic. But with the Lasso Selection tool, you can hand-
draw a selection around any object. The hard part of this 
is that you have to do it in a single click-and-drag motion. 
Since the Lasso Selection has to form a closed shape, if you 
don’t close it yourself by ending your drawing back on the 
starting point, the selection closes itself with a straight line. 
Once you’ve finished making a selection, you can drag the 
selection — not the underlying image, but the dashed line 
selection — around with the pointer, or nudge it with the 
arrow keys.

The Lasso Selection tool works well when the irregularly 
shaped object you want is well separated from other parts 
of the image. But in a photograph, for instance, you’re un-
likely to be so lucky. For such situations, Preview offers the 
Smart Lasso tool, which offers some assistance. When you 
drag, you see a thick red line instead of a thin white line — 

http://tidbits.com/article/16339
http://tidbits.com/article/16339
http://tidbits.com/article/16379
http://tidbits.com/article/16379
http://www.folklore.org/StoryView.py?story=MacPaint_Evolution.txt
http://www.folklore.org/StoryView.py?story=MacPaint_Evolution.txt
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draw that around the object you want to select and  
Preview tries to construct the selection intelligently. It will 
take some experimentation to get the desired results. Oddly, 
you can’t move a Smart Lasso selection afterwards with  
the pointer, but you can nudge it with the arrow keys.

Once you’ve selected something with one of these tools, 
you have a few options:

• Choose Edit > Invert Selection (Command-Shift-I) to 
select everything other than what you just selected. It’s 
handy at times!

• Press Delete to remove it from the image, leaving a hole.

• Use Command-C to copy the selection, so you can paste 
a copy into this or another image. Remember that you can 
also choose File > New from Clipboard to create a new file 
with the copied selection.

• Once you have a copy, you can move and resize it to 
your heart’s content, although it will always be essentially 
rectangular in Preview’s eyes, no matter how irregular it 
was to start. One technique we frequently employ is 
obscuring part of a screenshot by copying a chunk of its 
background color and pasting it over the part of the image 
we want to cover up.

Honestly, there aren’t that many uses for the Elliptical 
Selection tool, and both of the lasso tools are finicky, so we 
use them only occasionally. Let us know if you’ve found 
good uses for these tools, but if you’re just trying to remove 
a background from an image, the Instant Alpha tool is a 
better choice.

Instant Alpha — No, Instant Alpha won’t make you 
leader of the pack. Rather, it’s a color-based selection tool, 
similar to magic wand tools in other image manipulation 
apps. It’s best used to strip solid-colored backgrounds from 
images (replacing them with transparency, which doesn’t 
obscure the background color on a Web page, for instance).

The Instant Alpha tool is the second button in the Markup 
Toolbar. Click it, and then click and hold on the colored 
area you wish to select. The selected area turns red; you 

can then drag the pointer to adjust the tool’s sensitivity to 
include the colors you drag over. Once you’re happy with 
the selection, lift your finger from the mouse or trackpad to 
finalize your selection.

As you’d expect, you can press Delete to delete the selection. 
In the screenshot below, I first used Instant Alpha to select 
the background, which I deleted.

Then I undid that, selected the background again, inverted 
it with Edit > Invert Selection, and deleted the iPads and 
Apple Pencil, making for a neat silhouette effect.

Realistically, though, the main time we use the Instant 
Alpha tool is when we’re working on a button or logo for 
a Web site, and the original image has a white or colored 
background instead of a transparent background. A few 
quick clicks and the background is history.
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Adjust Colors — For the most part, we’ve been talking 
about editing images that someone created from scratch in 
a graphics app, rather than photographs. However, if you 
do find yourself needing to edit a photograph, Preview 
provides some surprisingly robust image adjustment tools 
when you choose Tools > Adjust Color (Command-Option- 
C). These tools are essentially identical to those that first 
appeared in iPhoto many years ago.

At the top of the Adjust Colors window is a histogram with 
three drag handles with which you can adjust the image’s 
white point, black point, and midtone. Click the Auto Levels 
button to get a suggestion of how to reset the white and 
black points. Then play with each of the sliders to get a feel 
for how they lighten or darken the image; if you don’t like 
how things turn out, you can reset all of your changes with 
the Reset All button at the bottom of the window.

The rest of the sliders are at least labeled, but we still  
recommend experimentation to see how each affects a  
given image. Remember, you can undo your adjustments 
at any time with Reset All. Here’s what they do:

• Exposure: If a photograph is too dark or too light due to 
being under-exposed or over-exposed, this slider will let 
you fix that. It’s mostly helpful in a small way to brighten 
photos that were dimly lit.

• Contrast: This slider lets you control the difference  
between the lightest and darkest areas in a photo. It’s 
seldom worth messing with much, though increasing 
contrast a little bit can make an image look crisper and 
more detailed.

• Highlights: This slider reveals detail in the brightest 
points of a photograph, which can be useful for making 
clouds more visible, for instance.

• Shadows: More generally useful than the previous one, 
the Shadows slider throws light on the darker parts of a 
photo, revealing detail that was previously hard to see. 
Since you’re most likely to use it on a dark photo, it will 
probably lighten the entire photo as well.

• Saturation: Use this slider to adjust how saturated the 
colors are. Moving the Saturation slider all the way to the 
left makes the image grayscale, which can be a useful 
effect, while sliding it to the right makes colors practically 
explode off the screen. If an image seems a little dull, try 
increasing saturation just a bit.

• Temperature: With this slider, you can make the image 
cooler (more blue) or warmer (more yellow). This isn’t 
terribly useful, but if the photo was taken in unkind  
fluorescent lighting, the Temperature slider might improve 
it a bit.

• Tint: While the Temperature slider lets you make an 
image more blue or more yellow, the Tint slider does the 
same with green and red. To make it easier to use, Apple 
provides a dropper next to it; select it and then click a part 
of the image that should be a neutral gray or white. That 
sets the Tint slider automatically. Click the dropper in a  
few different spots to see how they differ; the best way to 
evaluate how well it has worked is to look at some skin 
tones.

• Sepia: This slider is a one-trick pony; it reduces the 
saturation of the photo using sepia tones instead of 
grayscale. Crank it all the way up to give your image an 
“old-timey” feel.

• Sharpness: This slider can make your image blurrier or 
sharper. Blurrier might be helpful with an almost abstract 
sunset, but mostly you’ll want to sharpen photos to bring 
out more detail. Don’t go too far, though, since excessive 
sharpness can make the image look grainy.

To give an example of what these controls can do for your 
photos, here’s a photo Adam took recently at Cornell 
University’s Dragon Day. Unfortunately, because it was an 
overcast day, it looks less like a celebration and more like a 
funeral procession. Let’s see if we can brighten things up a 
bit.
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First, I clicked Auto Levels to establish a baseline, and then  
I moved exposure up a bit to brighten the image. But 
increasing exposure blew out some of the clouds, so I 
darkened the highlights to make it look more natural, while 
also lightening shadows a bit to add more brightness. Then 
I upped the saturation to make the bright colors in the 
photo more vibrant. Finally, I bumped up temperature, tint, 
saturation, and sharpness just a bit to round things out.

The end result is a brighter, clearer photo. Now there’s a 
celebration!

One last note about color. Preview supports color profiles, 
which define how different displays or printers can output 
color. In View > Soft Proof with Profile, you can choose a 
color profile with which to preview the image, and if you 
want to assign a particular profile, choose Tools > Assign 
Profile and pick a profile from the pop-up menu in the 
dialog that appears. These features could be useful for 
graphics professionals who care deeply about color repro-
duction, although we suspect they’re using different tools.

Rotate Photos and Pages — Every now and then, you 
end up with an image which isn’t rotated the way you 
want. Happily, Preview makes it easy to rotate images: 
choose either Tools > Rotate Left (Command-L) or Tools > 
Rotate Right (Command-R).

Less commonly useful than the Rotate commands are the 
next two in the Tools menu: Flip Horizontal and Flip 
Vertical. They rotate the image too, but around a horizontal 
or vertical center line. For example, Flip Horizontal can be 
helpful if you need a person’s headshot to face a different 
direction. Flip Vertical is useful when you need to flip a 
photo upside-down.

Preview can also rotate PDF pages, which is only very 
occasionally necessary. When you rotate a PDF page, 
Preview rotates just the currently selected page, which 
probably isn’t what you want. To instead rotate all pages, 
display thumbnails in the sidebar by choosing View > 
Thumbnails, select a page in the sidebar, choose Edit > 
Select All (Command-A) to select all pages, and then use 
the rotation commands. You can of course rotate just a 
subset of pages, if you want.

Crop Multiple Pages in PDFs — In “The Power of 
 Preview: Cropping and Resizing Images,” we said, 
“Preview crops only a single page at a time”. It turns out 
that’s not entirely true.

To crop multiple PDF pages, reveal the sidebar thumbnails 
as explained above and then use the Rectangular Selection 
tool on the page to select the area to which you want to 
crop (in the screenshot below, we’re eliminating the white 
page margins). Once you’ve made your selection, click the 
current page in the sidebar and choose Edit > Select All 
(Command-A) to select all the pages. Finally, choose Tools 
> Crop (Command-K) to crop every page in the document 
to the selected dimensions.
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Unfortunately, this still isn’t all that useful, because Preview 
only hides content instead of deleting it, and there’s no 
guarantee that other PDF viewers will honor the crop. It’s 
probably most useful if you’re trying, for instance, to make 
a bunch of postcards scanned as full pages into something 
more viewable.

Edit and Rearrange PDFs — As you’re probably com-
ing to realize, Preview gives you complete control over 
the individual pages in a PDF from the thumbnail sidebar 
view. Here’s what you can do:

• Rearrange pages: Click and drag a thumbnail in a  
sidebar and move the page to where you want it in the 
document.

• Delete pages: Select one or more thumbnails (by 
Shift-clicking for a contiguous selection or Command-click-
ing for a discontiguous selection) in the sidebar and press 
Delete.

• Combine PDFs: You can drag thumbnails from one 
document’s sidebar into the sidebar of another to copy 
pages between documents. Likewise, you can select all the 
thumbnails in a document’s sidebar and drag them into 
another document to combine the two. This is particularly 
handy for combining scanned single-page PDFs into a 
single file.

At this point, it might seem as though we’ve covered 
everything Preview can do, but we have more in the wings! 
Stay tuned to TidBITS to learn more about the power of 
Preview.

These days, when someone calls me on the 
phone when I’m at my desk, chances are 

I’ll take the call on my speakerphone, which happens to 
have a 27-inch Retina display and stereo speakers: in other 
words, my iMac. If you have a Mac running OS X 10.10 
Yosemite or later, and an iPhone running iOS 8 or later, you 
can set them up to do the same as long as both devices are 
on the same Wi-Fi network.

The first thing you need to do is to make sure your iPhone 
and your Mac are both signed into iCloud with the same 
Apple ID. On your Mac, you do this in System Preferences 
> iCloud; on your iPhone, you do it in Settings > iCloud.

Next, on your iPhone, go to Settings > Phone > Calls on 
Other Devices and turn that switch on. Then turn on the 
switch for your Mac, which appears on the same Settings 
screen; if you have other devices that also use the same  
Apple ID for iCloud, and you want to make calls with 
them, you can enable those devices as well.

by Michael E. Cohen

Phoning It in on Your Mac

With that out of the way, it’s time to make your Mac 
phone-friendly, and the key to that is FaceTime. Open the 
FaceTime app in the Applications folder and go to  

FaceTime > Preferences (Command-,) and enable Calls 
from iPhone. You may be asked to verify an emergency 
address for things like 911 calls; if so, go ahead.

If all goes well, that’s it. Your Mac and your iPhone are 
now buddies as long as both are on the same Wi-Fi network: 
any calls to your iPhone’s number will also ring on your 
Mac — as well as on any other devices you have enabled 
to receive calls from your iPhone. In my case, any call to 
my iPhone also rings on my Mac, two iPads, and my Apple 
Watch, so I have a wide choice of answering options! When 
a call comes into my iPhone, a notification appears on my 
Mac from which I can answer the call, decline it, or send 
it to voicemail using the pop-up menu attached to the 
notification’s Decline button.

Note, though, for the Mac to receive calls, your iPhone has 
to be on (it can be sleeping) and within Bluetooth range 
of your Mac; that is, unless you have also enabled Wi-Fi 
Calling on your iPhone (Settings > Phone) and in FaceTime 
on your Mac (FaceTime > Preferences). Wi-Fi Calling works 
on any 2012 or later Mac running OS X 10.11 El Capitan, 
with the exception of the mid-2012 “cheese grater” Mac 
Pro, and an iPhone running iOS 9. In the United States, Wi-
Fi Calling now works with all four major carriers: AT&T, 
Sprint, T-Mobile, and Verizon. For more on Wi-Fi Calling, 
see “Turn on Wi-Fi Calling in iOS 9” (28 October 2015).

So much for receiving calls. To make a call from your Mac, 
you have several options. One of the easiest is to use the 
Contacts app: go to the contact you want to call and then 

https://support.apple.com/en-us/HT204681
https://support.apple.com/en-us/HT204681
https://support.apple.com/en-us/HT203032
http://tidbits.com/article/16010
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hover your pointer over the phone number. A blue phone 
icon appears to the right of the number. Click the icon and 
your Mac calls that number.

If you see a phone number in an email message in Mail, 
a Web page in Safari, or a note in Notes, you can also use 
that number to make a call. Hover your pointer over the 
number, click to see the pop-up menu, and then choose the 
Call item.

For those who are old-school and like to dial phone 
numbers manually, you can do that as well. Launch 
FaceTime and type the phone number into the FaceTime 
search field. The phone number appears below the search 

field with a phone icon to its right: click the icon and 
choose the number shown in the menu.

FaceTime shows a notification as it attempts to make the 
call. Once the call connects, you can mute the call or end it 
from the notification, which stays on the screen as long as 
the call is in progress.

And what if the number you call is an automated phone 
system that requires you to enter numbers (“Press ‘1’ for 
more…”)? Not a problem: make sure the FaceTime notifica-
tion is selected and then enter numbers using the number 
keys on your Mac’s keyboard.

So the next time you’re working at your Mac and your iP-
hone rings in your pocket, don’t fumble around for it: take 
the call on the big screen.

For some years now, whenever I’ve been planning 
air travel, I’d start with the Kayak app on the 

iPhone. (It’s fine on the iPad too, but just as the best camera 
is the one you have with you, the iPhone is the best travel 
planner for me, because it’s always in my pocket.) With 
Kayak, you can quickly specify where you’re flying from 
and to (with an option to check nearby airports), your travel 
dates, and how many people are in your party. Kayak then 
shows both outbound and return flights as groups, sorted 
by price, and lets you filter the results to eliminate trips 
with too many stops, or with awkward departure or arrival 
times. But setting up all these options, and fiddling with 
your dates, if you’re flexible and looking for inexpensive 
flights, gets fussy fast.

by Adam C. Engst

Google Flights Offers 
a Slick Travel Planning Interface

So when I ran across a mention of Google Flights, a service 
that’s been around since 2011 but that I hadn’t heard of 
before, I gave it a try. Frankly, it’s an impressive demon-
stration both of what companies can do when they truly 
understand big data, as Google obviously does, and when 
designers put a great deal of thought into a Web-based 
interface that works for the user proactively.

The base interface is familiar: you choose a round trip, one-
way trip, or multi-city trip; set the class of ticket you want; 
and say how many tickets you need. Then it’s a matter of 
entering the cities you’re flying from and to, along with 
your preferred dates. Filter menus below the date picker let 
you restrict the results by number of stops, price, airline, 
departure and arrival time ranges, overall duration, and 
connecting airports.

https://itunes.apple.com/us/app/kayak-flights-hotels-cars/id305204535?mt=8&at=10l5PW
https://www.google.com/flights/
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But the niceties become evident quickly. For instance, I live 
in Ithaca, New York, and three nearby airports often have 
lower prices than the Ithaca Tompkins Regional Airport. 
Clicking the + button in the Departure Airport field reveals 
a helpful popup that lets me include those airports in the 
search, showing the best price at each for my dates, and 
how far away they are. You might already know all this for 
your home area, but Google Flights also provides the same 
nearby airport information and pricing for destinations, 
which you’re less likely to know. There’s nothing new 
about travel planning services checking nearby airports, 
but none I’ve seen does as good a job of highlighting lower 
prices.

Google Flights continues that highlighting in the Calendar 
view, where you pick departure and return dates. Airline 
pricing varies hugely depending on how long you stay and 
on which days you fly, but few travel planning services 
do more than check for alternatives within a day or two of 
dates you specify, and they seldom make it easy to see how 
pricing changes with dates.

In its Calendar view, once you enter a departure date, 
Google Flights shows the best fare in small type under 
each possible return date, coloring the best ones in green. 
A single click selects your departure date, and the next 
click selects your return date, but to explore the options for 
earlier departure dates, click the left-pointing arrow in that 
field. As you do, the best fares change on the fly as Google 
calculates the cascading effect that different dates have on 
the length of your stay.

Calendar view works well for me, but Google Flights also 
displays the same information in a Flexible Dates view. It 
offers a grid with departure dates running horizontally and 
return dates going vertically and the lowest fares highlighted 
in green. Depending on how you parse data, it may be a 
faster and more understandable way to zero in on the best 
combination of travel dates and fares.

The third and final date-related view in Google Flights is 
the Price Graph view, which shows the lowest fares for 
trips of different lengths, starting on different days. 
Honestly, this strikes me as the least useful view unless 
you’re planning a vacation where the dates are highly  
flexible and you want to optimize on price. But for us 
Type-A personalities who have to know we’re getting the 
best possible deal, the Price Graph view can provide some 
welcome reassurance.
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Once you’ve settled on your dates, it’s time to pick out-
bound and return flights. The first thing to notice is that if 
you were working quickly and didn’t optimize your dates 
for the lowest possible fare, Google Flights tells you that 
you could get a notably lower fare by leaving on a different 
date.

After you’ve picked a flight based on all the other standard 
variables, like departure time, total flying time, number 
of stops, and arrival time, Google Flights provides a clean 
display of the times and stops. Notably, it also helpfully 
provides more detail about the actual airplanes you’ll be 
flying in. As you can see in the screenshot, short flights out 
of Ithaca never have Wi-Fi or in-seat power, but the longer 
hop from Detroit to San Francisco will have both, along 
with on-demand video. It even displays the average leg-
room.

When you’ve selected both your outbound and return 
flights, Google Flights gives you the options to book your 
tickets (which often requires sending you to the individual 
airline sites), save the itinerary so you can watch it for price 
changes, and share it. There’s nothing particularly inno-
vative here, and it can be a shock to switch from the clean, 
smooth interface of Google Flights to the cluttered, awkward 
airline sites. I presume the airlines aren’t interested in 
giving Google unfettered access to their backend systems, 
much as it might be a win for the customer.

One caveat. After the initial publication of this article, 
several TidBITS readers weighed in with complaints about 
how Google Flights worked with international flights. I 
don’t have the experience or real-world opportunity to 
test such itineraries, but if you’re not in the United States, 
or are planning travel to other countries, take the Google 
Flights prices with a grain of salt until you can verify them 
on the airlines’ sites. As with all travel-planning services, 
Google Flights is only as good as its data, and nothing 
prevents you from trying Kayak or Expedia or Orbitz or 
any other competing service.

In the end, Google Flights isn’t revolutionary, but it offers 
such a compelling interface that it’s worth trying the next 
time you’re planning a trip.
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Rumors and Reality
by Tim Sullivan

Around Apple
•  Apple is opening up app subscriptions to all product 
categories. Developers will be able, for example, to charge 
$5 per year rather than just a flat $5 fee, for an ongoing 
revenue stream. Subscription fee changes are also being 
implemented. Currently, Apple takes a 30 percent cut of 
subscription fees on the App Store, but now, if a customer 
stays subscribed to a service for multiple years, Apple will 
only take a 15 percent cut, leaving 85 percent of profits for 
developers. 

What changes are coming?
–  Any app can offer auto-renewing subscriptions, but 
Apple will evaluate whether it fits its guidelines. We don’t 
yet know the full shape of what Apple will allow. 
–  Developers can price subscriptions at any of 200 different 
fixed price points, dramatically more options than before. 
–  Developers can charge different rates in different  
territories. 
–  Apps can offer not just different durations of subscriptions, 
but also different tiers, like standard, extra, and premium. 
–  Apps can have multiple non-overlapping subscriptions 
for different features or services. 
–  Subscription prices can change, and developers can 
choose to grandfather your existing price or inform you  
of an increase. 

Apple is adding ads to App Store search results, something 
that was hinted at earlier this year. Ads will be displayed 
when a search is conducted and developers will have 
opportunities to purchase those ads for better app 
exposure. There will be one ad on the search results page, 
which Apple will clearly denote as an ad.

Recently, the Apple TV Top Charts stopped displaying 
apps that a user has installed, and that’s a change that’s 
rolling out more widely. The “Featured” section in the App 
Store will change dynamically for each user, no longer 
displaying apps that are already installed and Apple plans 
to bring the Categories tab back to the App Store.  

•  Some hardware news: It looks like the function keys 
on MacBooks will be replaced by an OLED (organic 
light-emitting diode) bar. If the report is true, function keys 
(traditionally shrunken on all MacBooks) will be replaced 
by an OLED display touch bar. There are no details on the 
bar’s size and functionality, but it’s not hard to imagine 
many uses for what is essentially a second screen beneath 
the main one (and a touch-sensitive one at that.)

The pictures represent possible configurations, which 
include third party information.

Apple is introducing a brand new file system with 
“encryption as a primary feature”. Called the Apple File 
System (APFS), it is optimized for Flash/SSD storage and 
features strong encryption, copy-on-write metadata, space 
sharing, cloning for files and directories, snapshots, fast 
directory sizing, atomic safe-save primitives and improved 
file system fundamentals. APFS is released as a Developer 
Preview in macOS Sierra, and will ship in 2017. 

Apple File System can be described as a common file 
system that works across all its platforms (Mac, iOS, TV, 
Watch).

Another feature of APFS includes something called Space 
Sharing, which basically lets multiple file systems share the 
same underlying free space on a physical volume rather 
than use a fixed amount of space for each file system. In 
effect the system can use any free space it can find on the 
drive regardless of partitioning. This lets APFS grow and 
shrink without needing to repartition the volume. Further-
more, each volume in an APFS container reports the same 
available disk space, which is equal to the total available 
disk space of the container.

When it comes to security and encryption, Apple File 
System supports encryption natively. Full disk encryption 
has been available for years on both OS X and iOS and APFS 
now combines them into a unified model that encrypts file 
system metadata.

The following encryption models are available:
•  No encryption
•  Single-key encryption
•  Multi-key encryption
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Multi-key encryption is especially interesting. Based on 
per-file keys for file data and a separate key for metadata, 
this encryption model ensures the integrity of user data 
even when its physical security is compromised — for 
instance, if someone made a copy of your device’s whole 
flash storage it would be almost impossible to read the 
data.

APFS volumes currently don’t support Fusion Drive and 
FileVault, cannot be used as a startup disk or for Time 
Machine backups and filenames are currently case- 
sensitive only. APFS formatted volumes are not recognized 
on OS X 10.11 Yosemite and earlier and existing third party 
utilities will need to be updated to support the new file 
system.

We fully expect the aforementioned limitations to be 
addressed as APFS gets closer to its launch some time next 
year.

macOS

•  The next version of Mac system software is called macOS 
Sierra. It’s versioned as Mac OS X 10.12, and it will be 
available as a free download for all compatible Macs in the 
fall. 

If you’re Mac was made prior to 2009, you won’t be upgrading 
to macOS Sierra. This is the first Mac operating system 
update since OS X Mountain Lion from 2012 that drops 
support for older models.

According to Apple, the official compatible hardware list of 
Macs capable of running Mac OS Sierra 10.12 is as follows:

–  MacBook Pro (2010 and later)
–  MacBook Air (2010 and later)
–  Mac Mini (2010 and later)
–  Mac Pro (2010 and later)
–  MacBook (Late 2009 and later)
–  iMac (Late 2009 and later)

To verify your Mac’s version: Open the Apple menu in the 
upper left corner and choose “About This Mac,” “More 
Info...” and the “Overview” tab. The model and year will 
be displayed at the top of the panel

•  The Photos app will offer new Memories tab, where 
the app intelligently groups photos and videos in various 
“memories” that Apple hopes will let users relive expe-
riences in new and unexpected ways. There’s also an 
intelligent search feature which allows searching photos for 
objects and scenes and uses computer vision technology 
to identify matches, and a “Places” album which displays 
all your photos on a map of where they were taken. Apple 
also describes a “People” album as new feature, so I’m 
guessing it must just use a better version of Apple’s previ-
ous face recognition technology, since that has already been 
a feature of older version of macOS1, known as “Faces”.

The Photos app will now automatically cut together your 
photos and videos into an instant family movie, complete 
with a rich, algorithm-determined soundtrack.

•  MacOS is getting a feature that is called Picture in Picture, 
named after the pre-DVR television technology that allowed 
grown men with children to watch a World War II  
documentary on the big screen, while watching a World 
War I documentary on a tiny one in the corner.

•  In Safari 10, set to ship with macOS Sierra, Apple plans 
to disable common plug-ins like Adobe Flash, Java, Silver-
light, and QuickTime by default in an effort to focus on 
HTML5 content and improve the overall web browsing 
experience. On a website that requires a plug-in like Adobe 
Flash to function, users can activate it with a click as can be 
done in Google’s Chrome browser. 

•  macOS Sierra will be the first Mac operating system to 
include Siri. Although many people are familiar with how 
the virtual assistant works in iOS, there will be quite a few 
differences on desktops and laptops.

On current Mac models, at least, the main way you’ll 
trigger it is by clicking on a new Dock icon, although 
during the keynote, a keyboard shortcut also seemed to  
be available. In any case, there will be a Menu Bar icon in 
the upper right.

Where the Mac will come into its own, though, is integration 
with Finder. Although opening the app itself may be easier 
for locating specific files, Siri will allow searches according 
to broad criteria like when files were last opened or who 
sent them. The system will moreover support contextual 
follow-up commands, which can narrow down results. 
Really more than anything else, Siri for Mac feels like a 
merger between the Mac’s Spotlight search and iOS’ Siri. 
You can ask Siri how much free space is available on your 
Mac, or to show all the files in a particular folder,

Something that remains to be seen is how the Siri SDK 
might open up third-party app functionality. 

•  Paying on a Mac using TouchID on an iPhone: In its 
next logical evolution, Apple’s Apple Pay technology has 
made the jump from mobile apps and NFC terminals to 
the web. Now you can pay online using Apple Pay on any 
website that adds support for it. When you’re ready to pay, 
the payment details will show up on your iPhone, and all 
you have to do is place your finger on the home button, or 
double tap the side button on your Apple Watch. This of 
course comes with Apple Pay’s standard industry-leading 
security.

•  Universal Clipboard: Now when you copy something  
on your Mac it will be available automatically on the 
clipboards of your iOS devices, and when you copy on iOS, 
it will be available on your Mac

•  Cloud Drive Improvements: With macOS Sierra, the 
Desktop and Documents folders on your Mac can now 
sync with iCloud Drive, making them available to you on 
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all of your devices. There’s also a new Optimized Storage 
feature, in which the operating system will start offloading 
rarely used files into the cloud, where they will be available 
on demand, and will no longer take up valuable space on 
your Mac.

Of course, both of those features require that you have 
enough iCloud Drive space to store all those files in the 
cloud. Not surprisingly, Apple has still avoided changing 
their iCloud Drive storage tiers, with the free tier continuing 
to sit at a meager 5 gigabytes. On the bright side, Sierra’s 
space saving techniques extend a bit further than just 
sending things to iCloud Drive. Apple claims the new OS 
will also have tools to help you find and remove duplicate 
files, as well as unneeded or obsolete files hidden around 
your system.

iOS

•  iOS 10 will be released in the fall as a free download for 
iPhone, iPad, and iPod touch

iPhones compatible with iOS 10:

–  iPhone 6s
–  iPhone 6s Plus
–  iPhone 6
–  iPhone 6 Plus
–  iPhone SE
–  iPhone 5s
–  iPhone 5c
–  iPhone 5

iPads compatible with iOS 10:

–  iPad Pro 12.9 inch model
–  iPad Pro 9.7 inch model
–  iPad Air 2
–  iPad Air
–  iPad 4th generation
–  iPad Mini 4
–  iPad Mini 3
–  iPad Mini 2

iPod Touch compatible with iOS 10:

–  iPod Touch 6th generation

iOS 10 does not support iPhone 4s, iPad 2, iPad 3, and iPad 
Mini 1.

To determine which model you have, check the incredibly 
small and incredibly light writing on the back of your 
iPhone or iPad for the model number. Then go to Apple’s 
web site to match your model number with Apple’s.

iPad: https://support.apple.com/en-us/HT201471

iPhone: https://support.apple.com/en-us/HT201296

•  Apple announced that iOS 10 devices will transcribe 
voicemails.

•  The new iOS includes a complete redesign of its Messages  
app, which is used for sending SMS messages but also 
iMessages. The app saw a long list of updates. Messages 
suddenly has stickers. It has the option to add a “SLAM” 
animation to your message, either in an ironic mic drop or 
out of legitimate anger that your teen is out past curfew.

Then there’s Messages’ new emojify button. All you have 
to do is type your message into the app as always, and the 
button will instantly transform your words into vague, 
cartoonish emoji. Emojis have now been made three times 
larger on-screen.

•  Redesigned Lock Screen:  iOS 10 has redesigned the 
Lock screen, giving it a clear background even when  
notifications, presented in neat cards with rounded corners, 
are in view, a search bar at the top, with date and time being  
moved to right side. A host of info, including widgets, 
appointments, Map suggestions and Siri App Suggestions 
can be accessed by swiping from left on the Lock screen.

•  3D Touch-Powered Interactive Widgets: With iOS 10, 
certain apps are getting the capability to display an  
interactive widget of info with a 3D Touch-powered 
physical  hard-press. Some of the stock apps that  
supports this include Stocks, Weather and Calendar. 

•  Maps Redesign And Extensions: Since its disappointing 
debut years ago, the Maps app in iOS has seldom been 
deemed a viable alternative to the likes of Google Maps. It 
has taken a couple major iterations, but it seems Apple is 
finally gearing up to fix the problem. Not only has Maps 
been given a fresh coat of paint, it can now provide proac-
tive suggestions for places you are likely to visit from your 
current location, and the ability to search for places of 
interest, even while receiving turn-by-turn directions.

The most significant change here, however, is the app’s  
ability to integrate with third-party extensions, allowing 
users to make reservations at restaurants, book Uber rides 
and pay for it all through Apple Pay without ever having 
to leave the app.

•  Photos App Improvements And New Memories Feature: 
OS 10 adds an entirely new section called Memories  
within the Photos app, which is meant to help you 
reminisce about good times with friends and family ala 
Facebook’s On this Day offering. The tab intelligently 
collects photos from a trip, a get-together, or based on the 
people in your albums, and automatically sorts them into a 
collection called a Memory, which also contains the Memory  
Movie – a auto-generated video that contains all shots 
and clips from the collection punctuated by customizable 
titles, transitions and background music.

All of this is going to be made possible through “facial, 
object and scene recognition” built into iOS 10. The same 
capability will also allow you to search for photos by the 
people or objects within them.

•  New Home App For HomeKit: Apple has finally seen  
fit to introduced a simple but highly powerful app 

https://support.apple.com/en-us/HT201471
https://support.apple.com/en-us/HT201296
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for HomeKit called Home into iOS 10. Rather than having 
to use multiple third-party apps to control different aspects 
of the connected home, Apple now allow users to invoke 
the power of the new app to interact with and control all 
HomeKit-compatible hardware, either individually or in 
custom groups, through one powerful interface.

•  Removable Stock Apple Apps: With iOS 10, stock Apple 
apps can be deleted and then reloaded at will from the  
App Store. 

•  On the lighter side of things, intensity adjustment for  
the flashlight/torch? You got it.

Here’s the list of other iOS 10 features:

–  Read receipts by conversation in iMessages
–  iCloud Drive Desktop folder
–  Air Quality Index for China
–  Faster Camera launch
–  Continuity Clipboard
–  Autocorrect improvements for Korean & Thai
–  Notes collaboration
–  Unlimited tabs in Safari
–  Male and female Siri voices for Russia, Spain & Italy
–  Definition dictionary in Danish
–  Live Photos stabilization
–  Markup in Messages
–  Side-by-side Mail compose iPad
–  Location suggestions in Calendar
–  New iPad Camera UI
–  Live Filters for Live Photos
–  Conversation view in Mail
–  Discover in iBooks
–  Improved Auto Enhance in Photos
–  Faster FaceTime connectivity
–  CarPlay app reordering
–  Split View in Safari on iPad
–  Rest & type iPad keyboard
–  Sort Favorites in News
–  iCloud Drive Documents folder
–  Bilingual dictionaries in Dutch & Italian
–  Apple Pay in Safari
–  Mail suggested move folder
–  Air quality in Maps for China
–  Found in Messages
–  Brilliance adjustment slider in Photos
–  Mail filters
–  CarPlay on ultra wide screens
–  Bedtime alarm
–  Siri in South Africa & Ireland
–  Definition dictionary in Traditional Chinese
–  Live Photos editing
–  Avoid tolls in Maps
–  Mailbox column
–  Faster attachment sending in Messages
–  No Game Center app, service is still there.
–  Delete stock Apple apps
–  Re-download stock Apple apps from App Store
–  Panes in Control Center
–  New animations for opening and closing apps

–  3D Touch in Control Center
–  New Back button
–  New Folder view
–  App Store gets back Categories tab
–  Slide to unlock is gone from Lock screen, replaced by 
“press Home to unlock”
–  Read receipts for individual Contacts in Messages
–  New keyboard sound
–  Cellular Data option in 3D Touch Quick Actions
–  Take photos while listening to music
–  Optimized storage for Music
–  Today View in Notification Center removed from iPhone, 
still there on iPad
–  Widgets now show up on left side of Home screen, as 
well as left side on Lock screen.
–  Low intensity, Medium intensity, High intensity options 
for Torch/Flashlight
–  New file system called ‘Apple File System’
–  Home screen widgets in 3D Touch Quick Actions
–  Get Alerts on where you parked your car.
–  In-line video playback in Messages, Safari and other 
apps.
–  ReplayKit now allows live video streaming from apps 
and games, as well as screen-casting.
–  iPad as hub for HomeKit instead of Apple TV.
–  RAW support in Camera app.

watchOS

•  It’s not just a third draft; it’s a total rewrite

•  Both native apps and third-party apps will load much 
faster on watchOS 3, since favorite apps will be kept on the 
device’s memory. But Apple first had to admit that the 
current software has been painfully slow. 

•  There’s an SOS function, for making emergency calls. 

•  Apple is bringing its native Reminders and Find My 
Friends apps to the Watch so you can view your to-do lists 
and check them off and see how far away your friends (or, 
more likely, your family) are from you.

The Apple Watch has supported Apple Pay since day one, 
but now third-party app developers will be able to integrate 
Apple Pay as a payment option in their apps, which wasn’t 
available before.

•  Other changes were around health and fitness, since 
that’s one of the most popular use cases for the Watch. 
There will be a watch face made up entirely of Apple’s 
colorful activity-tracking rings, and another that offers a 
shortcut to the Workout app. People can share their activity 
data with other Watch wearers, so there’s finally a social 
component. And the Watch will soon track activity levels 
for people confined to wheelchairs. “Time to stand!” 
becomes “Time to roll!”

One of the Apple Watch’s most-used apps is Activity, 
which shows you how close you are to reaching your daily 
fitness goals with those addictive rings. Apple is giving 
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those features a huge upgrade in watchOS 3 with a Fitbit- 
like feature: competition. The next-gen operating system 
will put an activity-sharing feature on the watch. 

The Apple Watch is also getting a brand-new health app 
called Breathe, which guides you through meditative, 
deep-breathing exercises. The new app can be launched 
from the watch face, dock, or through notifications that  
remind you to breathe.

•  Rather than having to press firmly on the watch face 
to change faces, you can now just swipe, edge to edge, 
to change a watch face. Apple is ditching the idea of app 
“glances” on the Watch in favor of something more famil-
iar to iPhone users: an app dock, accessible by pressing 
the physical side button. Press the button, swipe through 
recent apps, and launch and interact with them from there. 
And now, when you swipe up from the bottom of the 
Watch’s face, you’ll see a mini control center — something, 
again, that is familiar to iPhone users.

•  A new feature in Apple’s WatchOS called Scribble will 
let you draw a message on your wrist under the table 
during dinner. That message will be sent from your Apple 
Watch.

•  Apple said people switch watch faces according to  
occasion, so it’s bringing new options to watchOS 3. 
There’s a new face called Numerals, a dancing Minnie 
Mouse to complement the existing Mickey face, and watch 

faces designed around activity rings, so you can see your 
daily rings in analog, chronograph, or digital versions. 
The next-gen watchOS also includes the ability to add 
Complications to faces, so you can see Weather on a photo, 
for instance.

tvOS

•  As expected, Siri will get some enhancements in the 
updated version of tvOS. The voice assistant can now 
search the system’s database of 650,000 movies and shows 
using more complex topical queries, such as the “high-
school comedies from the ’80s” example Apple VP Eddy 
Cue used onstage at the WWDC keynote. 

•  One of the biggest changes will use iOS as a proxy. The 
revamped Apple TV Remote app for iOS will now replicate 
all the features found in the hardware remote. It’ll use the 
phone’s mic for Siri queries, use its sensors for motion 
controls in games, and offer a touchpad interface. It’ll also 
(still) one-up the hardware remote by offering a keyboard 
for text input.

The other big change is that Apple TV has a new single 
sign-on feature, which lets you sign in once to authenticate 
all the apps that are part of your cable subscription. That 
update will also make it clear what you have access to in 
your app arsenal due to your cable package.

Brother Printer Drivers 4.0 for OS X
Jun 2, 2016 – 218.3 MB
System Requirements

–	 OS X Mavericks 10.9
–	 OS X Yosemite 10.10
–	 OS X El Capitan 10.11

This update installs the latest software for your Brother 
printer or scanner.

iTunes 12.4.1
Jun 2, 2016

This update addresses a number of problems where iTunes 
doesn’t work as expected with VoiceOver. It also restores 
the option to Reset Plays and fixes the following issues:
•  Up Next may have unexpectedly played songs added  
together in the incorrect order.
•  iTunes was prevented from crossfading between songs.

AirPort Base Station Firmware Update 7.7.7 
May 24, 2016
System Requirements

–	 AirPort Extreme and AirPort Time Capsule base 
stations with 802.11ac.

Firmware update 7.7.7 is recommended for all AirPort 
Extreme and AirPort Time Capsule base stations with 
802.11ac. This update improves the stability and  
performance of your base station.

This update:
• Fixes an issue which may prevent communication be-
tween clients on the same network
• Improves performance with an extended guest network
• Addresses potential naming conflicts with Bonjour Sleep 
Proxy

AirPort Base Station Firmware Update 7.6.7 
May 24, 2016
System Requirements

–	 AirPort Extreme, AirPort Time Capsule, and AirPort 
Express base stations with 802.11n.

Software Review

Apple Updates
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Firmware update 7.6.7 is recommended for all Apple 
802.11n Wi-Fi base stations including AirPort Express, 
AirPort Extreme and AirPort Time Capsule. This update 
improves the stability and performance of your base 
station.

This update:
• Fixes an issue which may prevent communication  
between clients on the same network
• Improves performance with an extended guest network
• Addresses potential naming conflicts with Bonjour Sleep 
Proxy

Security Update 2016-003 Yosemite
May 16, 2016 – 454.8 MB
System Requirements

–	 OS X Yosemite 10.10

Security Update 2016-003 is recommended for all users  
and improves the security of OS X.

OS X El Capitan 10.11.5 Update
May 16, 2016 – 759.1 MB
System Requirements

–	 OS X El Capitan 10.11.4

The OS X El Capitan 10.11.5 update improves the stability, 
compatibility and security of your Mac, and is recommended 
for all El Capitan users.

OS X El Capitan 10.11.5 Combo Update
May 16, 2016 – 1.53 GB
System Requirements

–	 OS X El Capitan 10.11

The OS X El Capitan 10.11.5 update improves the stability, 
compatibility and security of your Mac, and is recommended 
for all El Capitan users.

watchOS 2.0 - 2.2.1 
May 16, 2016
System Requirements

–	 iPhone 5 or later
–	 Available via OTA through the Apple Watch app

This release contains bug fixes and security updates.

This update includes support for pairing multiple watches  
to one iPhone, Maps improvements and new language 
support. This release also includes additional  
improvements and bug fixes.
•  Adds support for pairing multiple Apple Watches to one 
iPhone
•  Adds Nearby in Maps to browse for places around you 
by category, including Food, Shopping, and more
•  Adds support for system language in Catalan, Croatian, 
Slovak, Romanian, and Ukrainian
•  Adds support for dictation in Catalan, Croatian, Slovak, 
Romanian, Ukrainian, and English (Saudi Arabia, UAE, 
and Indonesia)
•  Adds support for Siri in Malay, Finnish, and Hebrew
•  Increases frequency of background heart rate  
measurements when you are stationary

Security Update 2016-003 Mavericks
May 16, 2016 – 370.9 MB
System Requirements

–	 OS X Mavericks 10.9

Security Update 2016-003 is recommended for all users and 
improves the security of OS X.

Share Keystone MacCentral with other MACaholics

Name  _______________________________________________________________________

Address	_____________________________________________________________________

City ______________________________________________ State	 ___  Zip	 _____________

Home Phone ___________________________	 Day Phone ___________________________

E-mail Address  _______________________________________________________________

Date  __________________			   Is this m Renewal or m New?	

How did you hear about us?  ___________________________________________________

Dues for one person are m $20/yr.		  Family or Corporate dues are m $30/yr. 

To join Keystone MacCentral, mail 
this form with your membership dues 
(payable to Keystone MacCentral) to: 

    Keystone MacCentral
          Membership Chair
    310 Somerset Drive
    Shiresmanstown, PA 17011

Keystone MacCentral meetings are 
held at 6:30 p.m. on the 3rd Tuesday of 
the month at Bethany Village Retirement 
Center, 5225 Wilson Lane, Mechanicsburg, 
PA 17055
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Bethany Village West 
Maplewood Assisted Living (Bld 21) 
5225 Wilson Lane 
Mechanicsburg, PA 17055

Turn onto Wilson Lane from Wesley Drive. Follow Wilson Lane until you see Bld 21 straight ahead.   
There is parking to the right.

If the door to Bld 21 is locked, press the “Intercom” button. Tell them you are attending the Keystone 
MacCentral computer meeting.

We will be in the Education Training Room.  In the lobby turn left, go to the end of the hall, and turn right.  
The Education Room is about half way down the hall, on the right.


