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Meet us at

Bethany Village Retirement Center
Education Room

5225 Wilson Lane, Mechanicsburg, PA 17055

Tuesday, April 18 2017 6:30 p.m.
Attendance is free and open to all interested persons.

Keystone MacCentral is having its annual auction 
on Tuesday April 18 at our regular meeting room in the 

Education Room of Bethany Village West 
Maplewood Assisted Living (Bld 21) 

5225 Wilson Lane 
Mechanicsburg, PA 17055

Annual Auction

The auction is open to both members and non-members so bring a friend.

Once again we will have a great list of vendors participating this year thanks to Eric Adams. 
That means lots of great software and hardware for you to bid on and great values. A great 
deal of thanks goes to the vendors who have been very supportive of users groups like ours. 
Go to our web site to see the latest list of goodies.

KeyMac will supply soft drinks and a few munchies. 

Come to what promises to be an enjoyable evening

http://www.keystonemac.com
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by Josh Centers

A Prairie HomeKit Companion:
Automating Your Home

At this point in our “A Prairie HomeKit Companion” 
series, you should be up and running with Home-

Kit home control. We first covered installing and setting up 
your Accessories and then discussed how you could control 
them individually and create Scenes to control them in 
groups. In this installment, I’m going to show you how to 
use Automations to toggle Accessories or Scenes when 
certain triggers fire.

Before you can automate HomeKit, you must have a device 
that can act as a hub: either a fourth-generation Apple TV 
or an iPad running iOS 10. The hub is necessary because 
something in the house has to be present to trigger Auto-
mations. Setting up a HomeKit hub confers an additional 
advantage: it lets you control your Accessories while 
you’re away from home.

The Hubbub About Hubs — Why can only Apple TVs 
and iPads work as HomeKit hubs? Why not AirPort 
base stations, which are already hubs of a sort? The reason 
is likely that the Apple TV and iPad both support Blue-
tooth, which controls many HomeKit devices. Why can’t 
you use a Mac as a hub? Your guess is as good as mine.

An iPad is slightly easier than an Apple TV to set up as a 
hub, and chances are better that you have one, so I’ll start 
there:

• In Settings > iCloud, make sure that you’re signed into 
your primary iCloud account.

• Also under Settings > iCloud, make sure that iCloud 
Keychain and Home are enabled.

• Go to Settings > Home and enable Use this iPad as a 
Home Hub.

It’s that simple! But here’s the trick: if you want your 
Automations to work while you’re out and about, your 
iPad must stay home! If you take your iPad hub with you, 
the Automations won’t work, because your hub isn’t 
connected to your home Wi-Fi network.

Therefore, if you own a fourth-generation Apple TV, it 
makes a better hub than the iPad, because it’s unlikely that 
you’ll take it out of the house. However, the trick here is 
that two-factor authentication must be enabled on your 
iCloud account. Note that this is different than Apple’s 
older two-step verification scheme, and if you have that 
enabled, you’ll have to disable it first to enable two-factor 

authentication. Apple explains this process in a support 
article, and I give easy, concise directions in “iOS 10: A Take 
Control Crash Course.”

Once you’re past that hurdle, using your Apple TV as 
a HomeKit hub is as simple as making sure that you’re 
signed in to your primary iCloud account under Settings > 
Accounts. You also need to have iCloud Keychain enabled 
on an iOS device or Mac.

Then, under Settings > Accounts > iCloud, you should see 
a HomeKit header, and under that, you should see Home: 
Connected. If you don’t, make sure everything is signed in 
properly.

The other way to check on your hubs is via the iOS Home 
app. First, if a hub isn’t responding, you’ll see that in the 
status messages on the Home screen. To see the status of 
all your hubs, tap the arrow in the upper left. Under Home 
Hubs, you’ll see your hubs and their statuses.

http://tidbits.com/series/1295
https://support.apple.com/en-us/HT204915
https://support.apple.com/en-us/HT204915
http://tid.bl.it/ios-10-crash-course-tidbits
http://tid.bl.it/ios-10-crash-course-tidbits
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To test if your hubs will work as you expect while you’re 
away from home, turn off Wi-Fi on your iPhone temporarily. 
Then, while you’re connected just via cellular data, try 
controlling your HomeKit Accessories. If your hubs are 
working properly, everything should work just as it does 
when you’re connected to Wi-Fi.

Finally, note that when it comes to HomeKit reliability, the 
more hubs, the better. I recommend setting up as many as 
you can, because if one disconnects or flakes out for some 
reason, you’ll have backups to ensure your Automations 
keep running. I’ve found HomeKit to be much more  
reliable since I added a second hub.

Once your hubs are set up, you can control your HomeKit 
devices from anywhere in the world! That works exactly 
the same as it does when you control HomeKit devices 
inside your home. You can also set up Automations because 
the hub will always be available to invoke them.

Automatic for the Home — The hardest part of setting 
up HomeKit Automation is getting the hubs in place. Then 
it comes down to figuring out what you want to do.

Just as with other aspects of home automation, be sure to 
communicate with your housemates and proceed carefully. 
If you set up an Automation to turn off the lights when you 
leave the house, you could leave your spouse and kids in 
the dark when you run to get ice cream.

It’s easy to go overboard on Automations, so I recommend 
keeping them simple. My wife wakes up at 5:30 AM, so I 
have my Good Morning scene set to light up the house for 
her. I then have my Good Night scene set to trigger at 8:30 
AM, because I don’t need the lights by that point. And then 
at 3:00 PM, Good Morning comes on again, so the house is 
lit up when she comes home from school.

I’d like to set up an Automation to turn outside lights on 
and off at appropriate times of day. We like to keep our 
exterior lights on at night for security reasons, but I often 
forget to turn them off during the day, which wastes power 
and reduces bulb lifespan. Our encased porch light could 
probably hold a Hue bulb safely, but Philips doesn’t make 
outdoor flood lights like we have on the side of the house, 
so I’d need to install something like Elgato’s Eve Light 
Switch to automate those lights.

If you had a HomeKit-compatible thermostat, you could 
also create an Automation to set the temperature down 
when you drive away in the morning and back up when 
you leave work.

That should give you a few ideas for useful Automations. 
What you want to avoid is making it seem like your house 
is haunted — lights turning off or on at seemingly random 
times, spooking everyone in the house.

Setting Up Automations — Once you set up a hub, the 
Automation screen in Home becomes available. In it, you 
can see existing Automations and set up four different 
Automation types: My Location Changes, A Time of Day 

Occurs, An Accessory Is Controlled, and A Sensor Detects 
Something. The steps for configuring them are roughly 
similar.

First, you tap Create New Automation in the Automation 
tab and then configure the trigger — the conditions that 
will cause the Automation to be invoked. Then you choose 
which Accessories and Scenes to turn on or off.

My Location Changes: I’m not wild about geofence  
triggers that go off when you arrive at or leave a 
specified location. They’re fine if you live alone, but 
if you share your house with others, they can create 
all sorts of problems unless everyone has the same 
schedule. For instance, there’s no way to configure 
the lights to turn off only if my wife and I both leave 
the house.

However, geofence triggers do have their uses. For 
instance, you could set up your outdoor lights to 
turn on when you approach your house. If you had a 
HomeKit-enabled garage door, you could even have 
it open automatically as you drive up.

To set up a location Automation, tap Create New  
Automation in the Automation tab and then My  
Location Changes.

At the Location Automation screen, first choose a trig-
gering location. This can be your home, a recently 
accessed Maps location, or a location you find in a 
search. Then choose whether to trigger the automa-
tion when you arrive at or leave the location. Finally, 
the map lets you adjust the trigger’s sensitivity. The 
red pushpin marks the spot, and you can drag the 
blue dot to adjust the trigger radius around the spot. 
Tap Next when you’re satisfied. 

https://www.elgato.com/en/eve/eve-light-switch
https://www.elgato.com/en/eve/eve-light-switch
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Once you’ve defined the location, choose Scenes and 
Accessories to activate. Tap Next.

The final screen lets you review your options and offers 
a few more tweaks. You can set the location trigger to 
work only after sunset. If you added any Accessories 
to the Automation, you can choose whether to turn 
them on or off; you can also press and hold on the 
Accessory button to make adjustments like brightness 
and temperature, just as you normally would when 
controlling it.

If you’re unhappy with any of the settings, tap Back to 
go back in the process and change things. If you’re 
satisfied, tap Done to finish.

A Time of Day Occurs: Setting a Time Automation works 
almost the same way, except at the Time Automation 
screen you choose the days and times when the 
trigger should go off. Two time options are sunrise 

and sunset, which are determined automatically 
based on where you live.

An Accessory Is Controlled: With this option, you can 
set HomeKit to activate something when you control 
an Accessory. For instance, if you turn on a light bulb, 
you could set smart plugs in the room to turn on 
lamps as well. I haven’t found a use for this option 
yet, but you might.

You start by choosing one Accessory that will trigger 
the automation. Next, choose whether to trigger the 
automation when the Accessory turns on or off. Then, 
choose Accessories and Scenes to activate with the 
trigger, and proceed as normal.

A Sensor Detects Something: In theory, you could set 
this to trigger actions when say, a smoke alarm or 
water detector is activated. However, even though 
I have an Elgato Eve Room sensor, which monitors 
air quality, temperature, and humidity, this option 
is grayed out. That’s unfortunate, because it would 
be great to use these sensors alongside a HomeKit 
thermostat to balance the temperature in my house 
better. If you know of a sensor that works with this 
trigger, let me know!

Editing Automations — Once your Automations are set 
up, you can view them from the Automations screen in 
Home. Tap one to see its settings.

It’s important to see how to disable an Automation, which 
is the first switch on the Automation settings screen. If you 
have a day off or know that you’ll be too sick to go to work 
the next day, you probably don’t want your lights coming 
on at 5:30 in the morning.

You can also change the triggers for the Automation and 
what Scenes and Accessories will be set by the automation.

Finally, there’s an option to delete the Automation. I seldom 
do this unless I’m just playing with test Automations that I 
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don’t intend to keep. Instead, disable an unwanted  
Automation first, and then delete it later if you don’t miss 
it.

HomeKit home automation is incredibly powerful, and it’s 
even better when you configure it to be truly automated. 
But as always, with great power comes great responsibility, 
so be careful what you set, discuss your Automations with 

other family members, and keep things simple so they’re 
easy to manage.

This concludes our coverage of the Home app, but we’re 
not done with HomeKit. Next time, I’ll tell you about a 
more powerful HomeKit app that gives you additional 
control over your devices.

by Josh Centers

Apple has released iOS 10.3, a major update 
which includes a new file system, lets 

you track your AirPods with Find My iPhone, and pro-
vides a host of other notable tweaks. You can install the 
560–650 MB update via Settings > General > Software 
Update or through iTunes.

The biggest new feature in iOS 10.3 is one you may not  
notice: it introduces Apple’s new Apple File System 
(APFS), which will eventually replace the legacy HFS+ file 
system currently in use on all of Apple’s platforms (see 
“What Apple’s Forthcoming APFS File System Means to 
You,” 24 June 2016). It remains to be seen what, if anything, 
this will mean for iOS users, but for now, the primary im-
pact is a longer update process than usual while it converts 
the existing file system. At iMore, Rene Ritchie has a good 
rundown on APFS’s benefits. So far, I’m finding iOS 10.3 
snappier than 10.2, but it’s impossible to say if that’s due 
to the new file system. Regardless, we always recommend 
backing up your devices before updating, but doing so is 
even more important with iOS 10.3.

Owners of Apple’s new wireless AirPods will appreciate 
that iOS 10.3 lets you track the little earbuds with Find 
My iPhone. You can either track their location on a map 
or make them play a locator tone. The sound is played on 
both AirPods and can be muted on each one individually, 
so if you drop one AirPod, you can silence the one you 
have so you can better hear the one you’re looking for. 
Given that replacing just a single AirPod costs $69, this 
new feature is extremely welcome (see “Apple’s Wireless 
AirPods Were Worth the Wait,” 20 December 2016). How-
ever, there’s a catch: the AirPods must be connected to (and 
thus in range of) a paired device for this feature to work.  
So while you should be able to locate an AirPod that 
disappeared into the couch cushions, you likely won’t be 
able to find one that you lost during a run.

iOS 10.3 Adds New File System,
Find My AirPods, and More

iOS 10.3 brings support for cross-device iTunes movie 
rentals, which Apple first introduced in iTunes 12.6 (see 
“iTunes 12.6,” 21 March 2017). Now, finally, you can rent 
iTunes movies on one device and watch them on another, 
though you’ll need iTunes 12.6, iOS 10.3, and tvOS 10.2 to 
do so.

Siri sees a few improvements with iOS 10.3, including 
support for paying bills in supported apps, scheduling in 
ride-booking apps like Lyft, and checking cricket scores 
and statistics for Indian Premier League and International 
Cricket Council. If you own a car that can be controlled 
via an automaker app, you gain some cool Siri capabilities, 
such as checking your car’s fuel level and lock status, 
turning lights on and off, and activating the horn. It’s 
probably still easier to slam your hand into the steering 
wheel than to say, “Hey Siri, BEEP!”

Speaking of cars, CarPlay gets a few new additions, such 
as app shortcuts in the status bar, Up Next and the current 
song’s album in Apple Music’s Now Playing screen, and 
access to daily curated Apple Music content.

https://support.apple.com/kb/DL1893
http://tidbits.com/article/16584
http://tidbits.com/article/16584
http://www.imore.com/apple-file-system-apfs-and-what-you-need-know
http://www.imore.com/apple-file-system-apfs-and-what-you-need-know
http://tidbits.com/article/16963
http://tidbits.com/article/16963
http://tidbits.com/article/17126
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Apple has rethought identity in the Settings app. Your 
identity now takes center stage above all other settings and 
provides a shortcut to a new, more coherent screen to handle 
your personal information, payment options, security 
settings, account information, and Family Sharing.

Apple has also addressed the problem of Calendar spam, 
which made the news late last year (see “How to Stop 
iCloud Calendar Spam,” 29 November 2016). You can now 
delete unwanted invites and report them as junk.

HomeKit sees some welcome improvements in iOS 10.3: 
you can now trigger scenes with switches and buttons, and 
the Home app now shows Accessory battery levels.

Other improvements include being able to search for 
“parked car” in Maps, a new widget and 3D Touch action 
for the Podcasts app, the option to share podcasts with 
full playback support in Messages, and hourly weather 
forecasts in Maps if you 3D Touch the current temperature. 
Also, iOS 10.3 addresses a bug with Maps that could pre-
vent it from showing your location after resetting Location 
& Privacy settings, as well as improving VoiceOver stability.

There are a couple of additions not mentioned in the 
release notes. In iOS 10.3, developers can now respond to 
App Store reviews. I’ve also noticed one small change in 
Mail: a count of unread Inbox messages in the back button 
when viewing an email thread. Lastly, iOS 10.3 includes a 
total of 67 security fixes!

When Should You Upgrade? — Honestly, although  
Apple doesn’t even mention the move to APFS in its user- 
level release notes, that’s the main reason to hold off. If 
there’s some subtle problem that surfaces only once 
hundreds of thousands of devices have updated to iOS 
10.3, you don’t want to be among that group. So we  
recommend waiting at least a week before installing iOS 
10.3, and perhaps longer if you don’t use AirPods, suffer 
from Calendar spam, or automate your house with 
HomeKit. After that, though, give it a whirl and enjoy the 
new features!

http://tidbits.com/article/16923
http://tidbits.com/article/16923
http://www.ibtimes.com/ios-103-update-apple-will-allow-developers-respond-app-store-reviews-2480750
http://www.ibtimes.com/ios-103-update-apple-will-allow-developers-respond-app-store-reviews-2480750
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The Dock has been a core aspect of the Mac  
experience since the earliest days of Mac OS X. 

In fact, the Dock actually predates Mac OS X, since it was 
also prominent in NeXTSTEP. It displays open applications, 
offers a quick way to launch favorite apps, and holds 
shortcuts for documents and folders.

You’ve probably used the Dock so often and for so long 
that you don’t think about it. We’ll explain everything the 
Dock does, from the basics to tweaky capabilities that may 
be new to you.

Today’s Dock is split into three sections, marked by dividing 
lines: Handoff, apps, and a third area that contains  
documents, folders, and the Trash.

Using Handoff in the Dock — Let’s dispense with 
Handoff first, since it’s a one-trick pony and not something 
that many Mac users who we know use.

The Handoff section contains only a single icon and appears 
only if your Mac is receiving a Handoff signal from another 
iOS device or Mac.

For instance, if you open a Web page in Safari on a 
compatible iPhone, you might see a Safari icon at the left or 
top of your Dock. Click that icon to open the iPhone’s Web 
page in Safari on your Mac. You might also see icons for 
Mail, Reminders, or other Handoff-savvy apps.

by Josh Centers 

macOS Hidden Treasures:
Dominate the Dock

For more on Handoff, check out Scholle McFarland’s 
“Sierra: A Take Control Crash Course,” which has an entire 
chapter about it.

Opening and Switching to Apps via the Dock — 
More commonly, the first section of your Dock contains 
apps that are either currently open or that you have saved 
to the Dock for quick access. Clicking an app either opens 
it or switches to it. In macOS 10.12 Sierra, open apps are 
denoted by a small dot underneath the icon (or on its side, 
if you’ve moved your Dock to the left or right edge of the 
screen). In earlier versions, the Dock gave open apps other 
markings, such as triangles.

If you don’t recognize an icon in the Dock, hover your 
mouse pointer over the icon and a tooltip appears showing 
the app name. This also works for documents and folders, 
where it’s even more useful, since their icons are often 
somewhat generic.

When your goal is to end up with a particular document 
open in an app, a more efficient way to open or switch to 
that app is to drop a compatible file onto it. For example, if 
you drag a text file from the Finder and drop it on TextEdit’s 
Dock icon, TextEdit opens with that document.

If you see an app icon with a question mark, it means that 
the source file has been deleted, thus breaking the Dock’s 
alias. You’ll need to figure out what happened to it in the 
Finder.

Although it’s hard to imagine anyone bothering to do this, 
you can also open an app via its contextual menu. Access it 
by clicking and holding, Control-clicking, right-clicking, or 
force-touching the Dock icon, and then choose Open.

Other App Actions from the Dock — Although the 
contextual menu is a silly way to open an app, it provides 
access to a wide variety of more useful actions that you can 
perform on apps:

•  Quit an app: To quit an open app from the Dock, choose 
Quit from the contextual menu. Unless you’ve set that app 
to stay in the Dock, its icon disappears from the Dock when 
it quits. Pressing Command-Q in the app is easier.

•  Force Quit an app: If an app is frozen and won’t quit 
via the usual method, open the app’s contextual menu and 
hold Option to turn Quit into Force Quit. Remember that 
Force Quit closes the app instantly, without prompting to 
save your work. We’ve found this more successful than 
the dialog you get by choosing Force Quit from the Apple 
menu.

•  Relaunch Finder: You can’t quit or force quit the Finder,  
but you can relaunch it if it’s giving you trouble. To do 
so, hold Option as you invoke the contextual menu and 
choose Relaunch. Note that Relaunch won’t appear if you 
press Option after opening the contextual menu, as it does 
for Force Quit.

http://tid.bl.it/sierra-crash-course-tidbits
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•  Keep an app in the Dock: If you’d like to be able to 
open a currently running app from the Dock at a future 
time, choose Options > Keep in Dock from the contextual 
menu. A check mark appears next to Keep in Dock. 

Another way to keep a running app in the Dock is to move 
it anywhere within the Dock. Click, drag, and drop, and 
the app will stay in the Dock.

Of course, you can also just drag any app icon from the 
Finder to the Dock to add it, whether or not it’s running.

• Remove an app from the Dock: The most intuitive way 
to remove an app from the Dock is to drag it far enough 
out of the Dock for the Remove popup to appear and then 
release. If you change your mind mid-drag, either drag the 
app back to the Dock or press the Escape key.

To remove an app from the Dock via the contextual menu, 
choose Options > Remove from Dock if the app is closed 
or Options > Keep in Dock if it’s open. (Remember, a check 
mark appears next to Keep in Dock if that option is en-
gaged.)

Note that removing an app from the Dock doesn’t affect 
the actual app, since the Dock icon is merely an alias. If 
you delete an app from the Dock, you can still find it in the 
Finder, usually in the Applications folder.

• Hide an app: If you don’t want to quit an app, but  
instead merely get it out of your way, you can hide its  
windows by choosing Hide from the contextual menu. 
Click the app’s Dock icon again to reveal the hidden app.

An easier approach is to Option-click the Desktop, any 
other app window, or any icon in the Dock. Or just press 
Command-H while the app is in the foreground.  
Of course, you can also minimize a single app window to 
the Dock, as explained below.

• Hide all but the selected app: To focus on a single app, 
you can hide all other app windows. Open the app’s 

contextual menu and press Option to turn Hide into Hide 
Others.

Again, a quicker way to Hide Others is to Command- 
Option-click the app’s Dock icon or press Command- 
Option-H while the app is in the foreground.

• Show all app windows: To invoke Mission Control in 
Application Windows view, choose Show All Windows 
from the contextual menu. Click a window to bring it to  
the front.

Another way to invoke Mission Control is to force touch 
the app’s Dock icon, if you have a sufficiently capable 
trackpad.

• Open an app at login: From the contextual menu, choose 
Options > Open at Login. A check mark appears next to 
Open at Login. To stop the app from opening at login, 
choose the same option again, and the check mark should 
disappear.

You can verify that this has happened by looking in System 
Preferences > Users & Groups > Login Items.

• Show an app in the Finder: Maybe you want to delete 
an app that’s in the Dock, or maybe you forgot where it’s 
stored. To reveal its actual location, open its contextual 
menu and choose Options > Show App in Finder.

• Assign app windows to a desktop: If you use multiple 
Mission Control desktops, it can be helpful to tie an app’s 
windows to a specific one. Under Options in an app’s 
contextual menu, you’ll see a Desktops header with a list  
of your desktops. Choosing a desktop moves that app’s 
windows to that desktop and keeps them there.

• App-specific commands: Apps can add their own com-
mands to their contextual Dock menus. So, for instance, 
Mail lists open windows in its menu and offers commands 
for Get New Mail, New Viewer Window, and Compose 
New Message. Every app with custom commands will be 
different, so be sure to check your most-used apps.

Docs and Minimized Windows in the Dock — The 
Dock can also hold documents and minimized windows. 
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To add a document, or, again, an alias to that document, to 
the Dock, drag it to the right side of the Dock, to the right 
of the divider. If your Dock is vertical, drop at the bottom, 
below the divider.

Click a document icon in the Dock to open it. The contextual 
menu offers a few extra options, but not many: Remove 
from Dock, Open at Login, and Show in Finder, the last of 
which is more useful than it is with apps.

You can even add Web shortcuts to the Dock. In Safari, 
click in the URL bar to reveal the full URL. Click and drag 
the favicon at the left of the URL bar down to the document 
section of the Dock to add a bookmark to that Web page to 
the Dock. This technique also works in Google Chrome and 
Firefox.

When you minimize a window, either by clicking the 
yellow minimize icon or choosing Window > Minimize, 
it shrinks into the same section of the Dock. Click a min-
imized window to expand it again. The contextual menu 
doesn’t offer any options for minimized windows other 
than opening them, and opening a minimized window is 
the only way to remove it from the Dock for good. Note 
that minimized windows look just like thumbnails of 
their windows with their app’s icon as a small badge —  
the badge differentiates a minimized window from a 
document icon.

Working with Folders in the Dock — Just as with  
documents, you can drag and drop folders to the right or 
bottom of the Dock. Clicking the folder in the Dock  
reveals a preview of the folder’s contents, but if you 
Command-click the folder, it instead opens in the Finder. 
You can also drag Finder items into a Dock folder to move 
them into that folder.

The Dock’s contextual menu for folders offers several 
options that let you customize how folders display in the 
Dock. First, you can set how the Dock preview sorts 
documents in the folder: by Name, Date Added, Date  
Modified, Date Created, or Kind.

You can also choose whether the folder appears in the 
Dock as a folder or a stack. Displaying it as a folder uses 
the same blue folder icon as in the Finder, while the stack 
shows a stacked preview of the files in the folder. This is 
purely an aesthetic choice, although the contents of some 
folders may lend themselves to one approach or the other.

More interesting is how you can customize the folder 
preview. Fan, which is an option only when the Dock is 
positioned at the bottom of the screen, shows the enclosed 
files in a curved stack with icon previews. Grid shows 
preview icons for the folder’s contents in a rectangle. List 
shows just a pop-up menu of file and folder names, and 
Automatic tries to choose which display to use based on 
how many items are in the folder.

Grid view is the most useful in general. It clearly shows 
all the files and folders in a format that’s easy to scan. You 
can also scroll through the files to see everything. Fan view 

shows too few items and is just strange, while List view is a 
bit too bare bones.

The Grid and List views also let you navigate into nested 
folders. Click a folder to reveal its contents in the Grid 
view; you can click the back button to go up one level. In 
List view, you can access nested folders via a hierarchical 
menu.

The main thing you’ll do in any of these views is open files 
and folders by clicking or selecting them. However, in Grid 
view, you can also drag files and folders from the preview 
to the Desktop, other folders, apps, and more.

Working with Trash in the Dock — Since the advent 
of Mac OS X, the Trash has lived in the Dock. It’s simple 
to use: click the Trash icon to open the Trash in the Finder, 
drag items to the Trash to delete them, and to empty the 
Trash, Control-click its icon and choose Empty Trash. 
Obviously, there are other ways of deleting files (we like 
pressing Command-Delete) and emptying the Trash 
(choose Finder > Empty Trash).

If you have an external drive that you want to dismount, 
or some form of removable storage (like a DVD) that you 
want to eject, start dragging it and the Trash icon becomes 
an Eject icon. It’s not intuitive, but matches the classic Mac 
behavior of dragging floppies to the Trash to eject them. 
You can also select the drive and choose File > Eject or 
press Command-E.
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Customizing the Dock’s Look and Feel — There are 
a handful of ways you can customize how the Dock as a 
whole looks and works. To get started, open System 
Preferences > Dock. You can also access the Dock preference 
pane by Control-clicking the divider between the app 
and document sections of the Dock and choosing Dock 
Preferences (when you mouse over the divider, the mouse 
pointer turns into a double-ended arrow).

The first setting is the size slider. If you have the screen real 
estate, larger is usually better. At its largest size, the Dock 
automatically scales to the size of the screen based on how 
many icons it contains.

You can also resize the Dock directly. Move the mouse 
pointer over the divider between the app and document 
sections until it becomes a double-ended arrow. Click and 
drag to adjust the Dock size.

Next, you can choose to turn on magnification and set how 
large you want the magnified icons to be. When magnifi-
cation is enabled, Dock icons enlarge as you mouse over 
them. It’s a cool effect that makes it easy to see icons that 
would otherwise be small.

The third option lets you change the position of the Dock 
— it’s perhaps the most important setting. By default, the 
Dock is displayed horizontally on the bottom of the screen. 
However, that’s almost always an inefficient use of space 
since nearly all screens are wider than they are tall, whereas 
most document windows are taller than they are wide. 

That leaves extra space on the sides of your screen, so it 
makes sense to pin your Dock vertically on the right or left.

Which side is better? Adam Engst prefers the right side 
because he uses two monitors, and positioning the Dock 
on the right side of the right-hand monitor prevents it 
from showing up awkwardly in the middle of the Desktop. 
Apple also offers a bit of guidance here. On the iPhone 
Plus models, when the phone is in landscape orientation, 
the iOS Dock appears on the right side of the screen. That 
makes sense in macOS too, since it keeps the Trash in the 
lower right of the screen.

The remaining Dock preferences provide mostly cosmetic 
tweaks:

• Minimize Windows Using: You can choose to minimize 
windows using either the Genie or Scale effect. It’s purely 
a cosmetic choice — try both and see which you prefer. 
Here’s an eye-candy tip: hold Shift as you minimize a 
window to see it sucked into the Dock in slow motion. 
Similarly, holding Shift as you click a minimized window 
(or folder!) expands it slowly.

• Prefer Tabs When Opening Documents: Why is this  
setting associated with Dock preferences? It makes no 
sense! The default is Always, but you can set it to In Full 
Screen Only or Manually. Unless you find app tabs useful 
in Sierra, you might want to set this to Manually.

• Double-click a Window’s Title Bar to: By default, this 
option zooms the window, but you can instead set it to 
minimize the window if you prefer that behavior. Of 
course, you can just use the green and yellow buttons in 
the upper left of any window to zoom and minimize too,  
or the appropriate commands in the Window menu.

• Minimize Windows into Application Icon: When this 
checkbox is selected, minimized windows don’t show up 
in the document and folder section of the Dock, but instead 
disappear into their associated app. That seems less useful 
to us, but your mileage may vary.

• Animate Opening Applications: This checkbox controls 
whether or not apps bounce in the Dock while opening. 
Seeing when apps take longer than expected to launch can 
be instructive when troubleshooting, so we recommend 
leaving it on.

• Automatically Hide and Show the Dock: When this 
setting is enabled, the Dock disappears unless you slam 
the mouse pointer to the edge of the screen that the Dock 
normally occupies. It’s a handy option for small screens 
— think about the 11-inch MacBook Air. You can also hide 
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and show the Dock with the Command-Option-D shortcut, 
which you can change in System Preferences > Keyboard > 
Shortcuts.

• Show Indicators for Open Applications: This option is 
on by default, and we can’t see any good reason to turn it 
off unless you’re offended by the little dots.

Outside of the Dock preference pane, System Preferences 
offers a few more relevant settings:

• Icon Badges: If you see a red circle in the upper-right 
corner of an app’s Dock icon, that’s a badge. Badges tell 
you things about the app, like how many unread messages 
Mail contains or if Slack has new messages. To turn badges 
off or back on for any given app, open System Preferences > 
Notifications, select the app in question and set the Badge 
App Icon checkbox as desired.

• Dark Mode: To darken up your Dock, open System 
Preferences > General and select Use Dark Menu Bar and 
Dock.

• Parental Controls: If you have a small child using a 
non-administrator account that’s managed by parental 
controls, you can prevent that user from modifying the 
Dock. Choose System Preferences > Parental Controls > 
user > Other and select Prevent the Dock from Being 
Modified.

The Dock is easy to take for granted, but it’s a key part of 
your everyday Mac experience. Mastering its nuances will 
help you work faster, more comfortably, and more efficiently. 
That’s all we can think of to share about the Dock, but it’s 
entirely possible that we’ve missed something. If so, let us 
know in the comments.

Rumors and Reality
by Tim Sullivan

Ever wondered how Siri learns a new language? Check 
9to5Mac to learn about the steps required.

32-bit apps are history. As a user, about the only way 
you have been able to tell if you are running a 32-bit app 
will have been a warning message that pops up:

“This app has not been updated to 64-bit. Using it may  
affect overall system performance.”

However, Apple will soon cease all support for 32-bit apps. 
As of iOS 10.3 you will find a new error message:

“This app will not work with future versions of iOS. The 
developer of this app needs to update it to improve its 
compatibility.”

In other words, this is the last chance for 32-bit apps 
pending introduction of iOS 11 later this year.

It is claimed that around 187,000 apps may be affected, in 
addition to the 47,000 apps that were removed from the 
store last Fall. This also means we’ll have fewer zombie 
apps in the stores.

Apple bought an automation app for iPhone and iPad 
called Workflow. The app is an extraordinary independent 
tool developed for iOS that lets users combine various 
apps in unique ways and automate certain processes on  
the iPhone or iPad.

As a direct result of Apple’s purchase of Workflow, the app 
is now available as a free download from the App Store. 

The developers found a way to work within the rules 
imposed by Apple to link apps together and automate  
certain tasks. Now that Apple owns Workflow, the app’s 

developers will be able to take advantage of APIs and  
resources that aren’t available to third-party programmers.

The US Senate has voted to overturn Internet privacy 
rules introduced last year by the FCC – and to prevent the 
FCC from passing any further such rules in the  future. The 
change paves the way for ISPs to sell your browsing history 
and location data to advertisers, who can use it to provide 
targeted advertising. Customers would lose the right to 
opt-out of such data sharing.

As to why senators would want to overturn privacy rules,  
it was reported earlier that the 22 Republican senators 
behind the resolution had received more than $1.7 million 
in campaign contributions from the telecoms industry in 
recent years.

https connections are one method that can help protect 
your privacy. Web encryption via an https connection from 
your browser protects end to end, though the Web server’s 
operator can obviously see what you’re up to. But nobody 
in between can.

With https, an ISP can intercept the name of the Web site to 
which you connect, but not the full URL with the path and 
potentially variables sent. It also can’t read interactions 
that happen in Web apps. It also prevents code injection, 
which some ISPs and hotspot operators use to insert popup 
messages, swap out or insert ads on a Web page, and 
otherwise interfere with the page sent from a Web site.

But ISPs can see how often you connect, when, and the size 
of payloads sent and returned, from which a lot of insight 
can be gleaned. You can’t rely on https to protect you from 
snooping, but it turns the dials down on a lot of specifics. 

https://9to5mac.com/2017/03/09/apple-speech-team-head-how-siri-learns-a-new-language/
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To ratchet it up a notch, you could use a virtual private net-
work (VPN) connection, which encrypts all the connections  
of any kind leaving your computer and decrypts it at some 
point on the Internet where the VPN operator has a  
termination point, usually in a data center, which can be 
located in a country that’s not your own.

VPNs have the advantage of cloaking everything. Neither 
an ISP nor any party between you and the VPN termination 
point can inspect what you’re doing, except the amount 
of traffic flowing. However, because you’re terminating 
at another point, this can slowdown throughput (the net 
amount of bytes flowing) and latency (the time between 
an action happening on one side of the connection and a 
response being received on the other). Depending on your 
network’s bandwidth and other factors, a VPN could slow 
you down or stall you quite a bit.

To read more about VPNs, read this MacWorlds article.

Apple has just released the official version of iOS 10.3 
for everyone, the last major software update for iPhones, 
iPads and iPods before the big iOS 11 roll out in June.

Don’t expect obvious changes in this version of iOS, but 
there are a few subtle tweaks that may be worth the  
upgrade.

Apple ID Profile

There’s a new profile section at the top of the settings menu 
with all your account information.

Click on your profile to access your iCloud, iTunes, App 
Store and Family Sharing information in one place and 
scroll down to see a list of all the Apple devices linked to 
these accounts.

You’ll still need to log in to the Find my iPhone app on 
your phone or web browser to access them all, but it will 
save you from having to dig through the settings to access 
each account.

iCloud storage breakdown

If you pay for extra storage on Apple’s iCloud, this next 
one will be especially useful. You can now see exactly how 
you’re using your iCloud storage by clicking on the iCloud 
option in this new profile section. Tap the graph at the top 

of this section to figure out exactly what the storage hogs 
are. This gives you a device and program-specific break-
down detailing how many gigs of storage are being used 
by each.

If you haven’t activated the two-factor authentication on 
your account (which you should), you’ll notice a new 
“suggestion” section right below your profile in the main 
settings page. Apple may use this space to give you other 
suggestions to improve your device’s performance, but 
for now this is the only suggestion that appeared on my 
phone.

Weather in Maps

If you’re a fan of Apple’s proprietary Maps app, you will 
now have a glimpse of the weather wherever you go. The 
latest update adds a tiny weather bug to the bottom right-
hand corner of the screen showing the current weather 
conditions in that area. For a seven-day breakdown of 
the weather just 3D Touch the weather bug or continue 
holding to open the weather app in a new screen.

Find my AirPods

If you’ve splurged on a pair of AirPods, this feature will 
save you time and money. If not, just read ahead.

Sign in to your Find my iPhone app and you should now 
see the AirPods as one of the devices associated with your 
account. Click to see the last known location of the ‘Pods 
when they were paired with your phone or ping them to 
make them ring. Just make sure you’re not wearing them  
if you want to keep your hearing intact.

App compatibility status

Chances are, you may be holding on to a few apps that 
have stopped receiving updates, which could be making 
your phone sluggish and buggy.

iOS 10.3 makes it easy to identify the culprits right from  
the Settings menu. Click on the About option on your 
General settings and wait for the information to load. If 
you have any non compatible apps lying around, you 
should see an arrow appear next to the number next to  
Applications. Another click should then take you to the 
App Compatibility page listing the offenders.

Software Review

FotoMagico is a program that makes creating video slide-
shows a snap. Throwing together a quick and dirty 
presentations can be accomplished in minutes. But the 
programs has enough bells and whistles to create truly 
sophisticated slide shows. In fact besides the home user, 

FotoMagico the other audience is professionals who want to create 
presentations for their customers.

The Quick & Dirty

When FotoMagico is first opened it will ask which format 
are you going to use. My photos are in 4:3 format, so that is 
my format of choice.

http://www.macworld.com/article/3186967/os-x/protect-against-potential-isp-snooping-by-using-https-and-a-vpn.html
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On the Toolbar choose Images, Movies, or Audio. That will 
open the appropriate Sidebar. Folders can be dragged into 
the Sidebar, but files cannot be dragged in. Select a folder 
to display the contents. Then drag the selected images to 
the storyboard. Selected images can be added, moved, or 
deleted from the storyboard. Each slide can be enlarged, 
reduced, and rotated.

By selecting Add Title from the Toolbar, slides can be 
annotated.

Create layers by dragging other images on top of existing 
images. Each layer can be manipulated separately. 

Slides may be flagged with a warning symbol. The white 
exclamation mark indicates that the slide as formatted will 
take too long to load. Click on the exclamation point to fix 
the problem. Yellow exclamation marks means that the 
transition duration is too long. This can be fixed in Options.

Select Options on the Toolbar to set various parameters of 
your slides. The Options will be applied to the slides that 
are selected.

An animated slide with three layers

Some available options
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• Slides: Set animation, duration, and Continue After…

Enabling Animation results in a Start and a Finish frame 
displayed on the Stage. 

Duration sets the time that the slide together with its 
transition is displayed.

Continue should be set to After Duration. 

• Transitions: choose a Type and Duration.

• Layers: this is where you can get creative. The Visibility 
options allows a layer to fade in or fade out. Experiment 
with masking for some really interesting effects.

• Title provides settings for any title: Font, style, size, 
alignment, color. Choosing More… allows for Kerning 
(horizontal spacing), Leading (vertical spacing), and Shadow.

• Audio: set the Volume, Fadein, Fadeout, and Audio 
Loops. Check this last one if you have a very short audio. 
You may or may not want it to loop.

After adjusting the storyboard to your satisfaction it’s time 
to add audio. Select Audio in the Titlebar. Your iTunes 
library should be available, and you can drag a folder of 
music in the Sidebar.

Snippets (more about these shortly) can be loaded with 
music from the web site.

The last step is to Share your slide show. There are several 
options to choose from depending on where you want to 
view the final product. The various choices will result in 
different resolutions and sizes. I would suggest trying 
several different choices the first time you do this to  
determine which suits best.

More Advanced and Fun Stuff

One of the target audiences is professionals who want to 
create presentations. Most of the Snippets are designed for 
them. Snippets are frameworks into which the users put 
their own individual information. Prebuilt introductions 
and titles can be used to open the show while credits at the 
end can identify anyone and everyone involved. 

There are two types of Snippets that the casual user may 
find interesting: Splitscreens and Effects.

Splitscreens allow for two to four pictures to be presented 
on a single slide. Animations can be applied. The Photo 
Pile effect allows three pictures to be piled into a single 
slide.

When necessary to match a layers on the Stage when  
animating use Copy and Paste Geometry in the Edit menu.

There is a Narration Assistant available. I’m guessing this 
allows the user to record verbal notes that can be attached 
to the slide show.

There is a Timeline view of the storyboard — probably 
only available on the extra cost version. This combined 
with setting the slides to continue At Audio Marker allows 
the slides to be synced with the beat of the music. 

The blank slide can be inserted into the storyboard. I like to 
use it for effect especially at the beginning of a slide show. 
I start the music and give the audience time to settle down 
before actually starting.

A splitscreen from Snippets. Drag image to the stage.

A Photo Pile from Snippets

Apple Updates

iOS 10.3 Information
Mar 27, 2017
System Requirements

– iPhone 5 or newer
– iPad 4th generation or newer
– iPad mini 2 or newer
– iPod touch (6th generation)
– Available via OTA and iTunes

iOS 10.3 introduces new features including the ability to  
locate AirPods using Find my iPhone and more ways to 
use Siri with payment, ride booking and automaker apps.

Find My iPhone
•  View the current or last known location of your Air-

Pods
•  Play a sound on one or both AirPods to help you find 

them

Siri
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•  Support for paying and checking status of bills with 
payment apps

•  Support for scheduling with ride booking apps
•  Support for checking car fuel level, lock status, 

turning on lights and activating horn with automaker 
apps

•  Cricket sports scores and statistics for Indian Premier 
League and International Cricket Council

CarPlay
•  Shortcuts in the status bar for easy access to last used 

apps
•  Apple Music Now Playing screen gives access to Up 

Next and the currently playing song’s album
•  Daily curated playlists and new music categories in 

Apple Music

Other improvements and fixes
•  Rent once and watch your iTunes movies across your 

devices
•  New Settings unified view for your Apple ID account 

information, settings and devices
•  Hourly weather in Maps using 3D Touch on the 

displayed current temperature
•  Support for searching “parked car” in Maps
•  Calendar adds the ability to delete an unwanted  

invite and report it as junk
•  Home app support to trigger scenes using accessories 

with switches and buttons
•  Home app support for accessory battery level status
•  Podcasts support for 3D Touch and Today widget to 

access recently updated shows
•  Podcast shows or episodes are shareable to Messages 

with full playback support
•  Fixes an issue that could prevent Maps from  

displaying your current location after resetting  
Location & Privacy

•  VoiceOver stability improvements for Phone, Safari 
and Mail

Security Update 2017-001 (Yosemite)
Mar 27, 2017  495.2 MB
System Requirements

– OS X Yosemite 10.10.5

Security Update 2017-001 is recommended for all users  
and improves the security of OS X.

macOS Sierra 10.12.4 Update
 Mar 27, 2017  1.79 GB
System Requirements

– macOS Sierra 10.12.3

The macOS Sierra 10.12.4 update improves the stability, 
compatibility, and security of your Mac, and is  
recommended for all users.

This update:
• Adds Night Shift for automatically shifting the colors 

in your display to the warmer end of the spectrum 
after dark

• Adds Siri support for cricket sports scores and  
statistics for Indian Premier League and International 
Cricket Council

• Adds Dictation support for Shanghainese
• Resolves several PDF rendering and annotation issues 

in Preview
• Improves the visibility of the subject line when using 

Conversation View in Mail
• Fixes an issue that may prevent content from  

appearing in Mail messages

macOS Sierra 10.12.4 Combo Update
Mar 27, 2017  2.04 GB
System Requirements

– macOS Sierra 10.12

The macOS Sierra 10.12.4 update improves the stability, 
compatibility, and security of your Mac, and is  
recommended for all users.

This update:
• Adds Night Shift for automatically shifting the colors 

in your display to the warmer end of the spectrum 
after dark

• Adds Siri support for cricket sports scores and statistics 
for Indian Premier League and International Cricket 
Council

• Adds Dictation support for Shanghainese
• Resolves several PDF rendering and annotation issues 

in Preview
• Improves the visibility of the subject line when using 

Conversation View in Mail
• Fixes an issue that may prevent content from appearing 

in Mail messages

watchOS 3.0 - 3.2 Information
Mar 27, 2017
System Requirements

– iPhone 5 or later
– Available via OTA through the Apple Watch app

This release introduces the ability to use Siri with apps and 
Theater Mode to keep the screen dark until you tap it. This 
release also includes additional improvements and bug 
fixes.

•  Siri now works with apps from the App Store to start 
workouts, send messages, make payments, book 
rides, and more.

•  Theater Mode setting turns on silent mode and keeps 
the screen dark until you tap it, even when you raise 
your wrist.

•  Scribble is now available in French, Spanish, and  
Italian.

•  Music playlist sync progress is now displayed in the 
Apple Watch app on iPhone.

Security Update 2017-001 (El Capitan)
Mar 27, 2017  700.6 MB
System Requirements

– OS X El Capitan 10.11
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Security Update 2017-001 is recommended for all users  
and improves the security of OS X.

iTunes 12.6
Mar 21, 2017
This update includes minor app and performance  
improvements.

Turn onto Wilson Lane from Wesley Drive. Follow Wilson Lane until you see Bld 21 straight ahead.   
There is parking to the right.

If the door to Bld 21 is locked, press the “Intercom” button. Tell them you are attending the Keystone MacCentral  
computer meeting.

We will be in the Education Training Room.  In the lobby turn left, go to the end of the hall, and turn right.  
The Education Room is about half way down the hall, on the right.

�

Bethany Village West 
Maplewood Assisted Living (Bld 21) 
5225 Wilson Lane 
Mechanicsburg, PA 17055


