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October Presentations
This month we have a group of presentations. Time permitting we will get to most of them.
• A video by David Cox talking about Mojave and Metal. Mojave requires Metal that is system
software installed only in the latest Mac hardware.
• PullTube is a beautiful online video downloader for your Mac. 8K, 4K, HD, 60fps, VP9 encoded
video and playlist support. Convert videos to MP3 and M4A on the fly.
• Malwarebytes protects you against malware, ransomware, and other advanced online threats
that have made traditional antivirus obsolete and ineffective.
• Software to retrieve pictures from an erased camera card.

Meet us at

Bethany Village Retirement Center
Education Room
5225 Wilson Lane, Mechanicsburg, PA 17055

Tuesday, October 16th 2018 6:30 p.m.
Attendance is free and open to all interested persons.

Contents

Board of Directors

October Presentation .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 1
When and How to Upgrade to iOS 12, watchOS 5, tvOS 12,
and macOS 10.14 Mojave by Adam Engst .  .  .  .  .  .  .  .  .  .  .  . 3 - 4
Get Ready for iOS 12 by Backing Up, Cleaning Up,
and Updating Apps By Josh Centers .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 5 - 7
Popular Mac App Store Utility Turned Out to Be Spyware
By Josh Centers.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 7
TipBITS: How to Move Your Evernote Notes to Apple’s Notes
By Josh Centers.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  7 - 8
The Big News about macOS 10.14 Mojave Is Dark
By Michael E. Cohen.  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .8 - 10
Software Review .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  11

Keystone MacCentral is a not-for-profit group of Macintosh enthusiasts who
generally meet the third Tuesday of every month to exchange information,
participate in question-and-answer sessions, view product demonstrations, and
obtain resource materials that will help them get the most out of their computer
systems. Meetings are free and open to the public. The Keystone MacCentral printout
is the official newsletter of Keystone MacCentral and an independent publication
not affiliated or otherwise associated with or sponsored or sanctioned by any
for-profit organization, including Apple Inc. Copyright © 2018, Keystone MacCentral,
310 Somerset Drive, Shiresmanstown, PA 17011.
Nonprofit user groups may reproduce articles form the Printout only if the
copyright notice is included, the articles have not been edited, are clearly
attributed to the original author and to the Keystone MacCentral Printout, and
a copy of the publication is mailed to the editor of this newsletter.
The opinions, statements, positions, and views stated herein are those of the
author(s) or publisher and are not intended to be the opinions, statements,
positions, or views of Apple, Inc.

President
Linda J Cober
Recorder
Wendy Adams
Treasurer
Tim Sullivan
Program Director
Dennis McMahon
Membership Chair
Eric Adams
Correspondence Secretary
Sandra Cober

Newsletter Editor
Tim Sullivan
Industry Liaison
Eric Adams
Web Master
Tom Bank II

Throughout this publication, trademarked names are used. Rather than include a
trademark symbol in every occurrence of a trademarked name, we are using the
trademarked names only for editorial purposes and to the benefit of the
trademark owner with no intent of trademark infringement.

Keystone
MacCentral
Essentials
Meeting Place
Bethany Village West
Maplewood Assisted Living (Bld 21)
5225 Wilson Lane
Mechanicsburg, PA 17055
Web Site

http://www.keystonemac.com
Mailing Address
310 Somerset Drive

Shiresmanstown, PA 17011

Oct 2018 Page 2

by Adam Engst

When and How to Upgrade
to iOS 12, watchOS 5, tvOS 12,
and macOS 10.14 Mojave

As

promised at its special event last week, Apple
today released iOS 12, watchOS 5, and tvOS 12.
We’re assuming that the company will stick to its plan to
push out macOS 10.14 Mojave next week on September
24th.
Should you drop everything and download the updates
immediately? If you’re an unrepentant early adopter, like
many of us here at TidBITS, the answer is, “Obviously!”
More power to you! May your downloads be quick and
your backups be recent.
However, if you generally fall on the cautious side, or if
you can’t risk your devices not working perfectly, here’s
our advice on when you should think about installing
these new versions.

iOS 12
Several of us here at TidBITS have been using iOS 12 betas
all summer, and it has been a largely positive experience.
We’ve heard from readers with older devices that its
performance improvements have given a new lease on
life to the iPhone 5s, iPad Air, and the like. One TidBITS
Talk reader said it solved his iOS 11 battery problems. Josh
Centers devoted his summer to Take Control of iOS 12, so
you can read that for the full rundown on what’s new and
necessary.

That said, you’ve been waiting this long, so what’s another
week or two? We recommend holding off on installing iOS
12 for a bit, just to make sure no pressing problems crop
up. If any widespread issues affect the iOS community,
we’ll be sure to pass on the details.

During that time, Apple will likely release a few bug fix
updates like iOS 12.0.1 and 12.0.2. A few months later, the
company usually issues a feature update that will probably
be version iOS 12.1. But do install iOS 12 before too long,
since otherwise you’ll be at risk for newly discovered
security vulnerabilities that Apple doesn’t fix for older iOS
versions.
When you are ready to upgrade, first read “Get Ready for
iOS 12 by Backing Up, Cleaning Up, and Updating Apps”
(10 September 2018). iOS 12 varies in size by device: we’ve
seen it range from 1.35 GB on a 10.5-inch iPad Pro to 2.26
GB on an iPhone 5s. Once you’ve backed up to iCloud and
iTunes (read the referenced article for why we say “and”),
install iOS 12 by going to Settings > General > Software
Update and tapping Download and Install. You can also
install it through iTunes, but we recommend the over-theair update instead due to Apple’s waning interest in
iTunes.

iOS 12 on HomePod
We had no early access to the HomePod update that Apple
just released, but after some quick installation and testing,
there doesn’t seem to be any reason to wait. It’s possible
that the device from which you initiate the installation may
need to be running iOS 12. We were interested to see that
Apple is calling the update “iOS 12” and not “HomePod
12” or “homeOS 12.”
The new features aren’t huge, but they’re still extremely
welcome, particularly the capability to make and receive
phone calls directly (for more on that, see “HomePod First
Impressions: Let the (Apple) Music Play,” 12 February 2018,
and “Beyond Music: Comparing the HomePod to Amazon
Echo and Google Home,” 15 March 2018). You can also
search for songs in Apple Music by their lyrics (in the US,
UK, Australia, and Canada), set multiple timers, and ping
your other iOS devices to locate them.

If you’re change-averse, there’s no harm—apart from
reduced performance and not taking advantage of new and
enhanced features like Screen Time and Do Not Disturb
— in waiting a few more weeks, or even a month or two.
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To install iOS 12 on the HomePod, open the Home app on
your iPhone or iPad, tap the Details link under “HomePod
software update available” and on the next screen, tap Install.
At 1.5 GB, it’s a big download, but it installed reasonably
quickly. The tricky part with the new capabilities is that
you have to train yourself to invoke them with Siri.

To install watchOS 5, open the Watch app on your iPhone,
go to My Watch > General > Software Update, and tap
Download and Install. It’s a 340 MB update on my Apple
Watch Series 2. Remember that the Apple Watch must be
on its charger, charged to at least 50 percent, and within
range of your iPhone, which itself must be on Wi-Fi. The
update may take longer than you think it should—we
recommend updating while you sleep. In fact, your Apple
Watch may even suggest an overnight installation.

tvOS 12
Although we didn’t test betas of tvOS 12, readers have said
that it has worked well. The promised changes are minimal: Dolby Atmos support for the Apple TV 4K, the new
Earth screensaver, tapping the touchpad to identify
an Aerial screensaver location, password autofill, an
automatically added Apple TV Remote button in an iOS 12
device’s Control Center, and improvements for some TV
providers (zero sign-on and cloud DVR support).
Unless you live and die by your Apple TV, we see no
reason to delay the upgrade. For most people, tvOS is
probably set to update itself automatically, and that’s fine.
Let it install tvOS 12 whenever it wants, or force it to update
right away in Settings > System > Software Updates.

macOS 10.14 Mojave
watchOS 5
As with iOS 12, I’ve been running watchOS 5 on my Apple
Watch Series 2 for a month or two, and I’ve experienced no
problems. The new capabilities may not be game-changing
unless you’re looking forward to Walkie-Talkie conversations
with a friend or family member or if you regularly forget to
start the Workout app before going for a run — the
auto-start capability is welcome.
watchOS 5 requires that you are running iOS 12 on your
Apple Watch’s associated iPhone, so we recommend that
you upgrade to watchOS 5 as soon as you upgrade to iOS
12. watchOS 5 works with all models except the original
Apple Watch.

The release version of Mojave should become available for
download on 24 September 2018. It poses a significantly
trickier upgrade question. Even if you were testing the betas
of Mojave, you probably weren’t doing so on your main
Mac. Your experiences during the beta period should have
given you a sense of whether you can install on Macs that
you rely on to get your work done — you should know by
now if your essential apps are compatible or not.
I’ve been running Mojave betas all summer on my MacBook
Air, and honestly, I will not be installing the final release of
Mojave on my 27-inch iMac right away. I’ve seen too many
quirks and problems, a number related to the new privacy protections (see “Mojave’s New Security and Privacy
Protections Face Usability Challenges,” 10 September 2018).
Some of my Keyboard Maestro macros have stopped
working, and I haven’t yet been able to figure out why. I’ve
also been annoyed by the constant nagging of utility apps
asking to control other apps or access privacy-protected
data.
Therefore, I recommend that you wait to install Mojave on
your main Mac until two things are true:
Apple has released at least 10.14.1, if not 10.14.2. We
hope those updates will squash early bugs and
smooth out the authorization requests.
You have verified, through community comments or
discussions with developers, that your essential apps
—particularly utilities!—will run properly in Mojave.
If you have a secondary Mac that’s not crucial to your
workflow, go ahead and install Mojave there.
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By Josh Centers

Get Ready for iOS 12 by Backing Up,
Cleaning Up, and Updating Apps

It’s

that season again. iOS 12 is likely due next week,
making now the best time to take a few minutes
to get your devices ready. I’ve been using the iOS 12 betas
all summer as I wrote Take Control of iOS 12, and based on
my experience, I expect a drama-free update this year. That
said, there are some things you always want to do before
major iOS updates—if nothing else, it’s a good time to do
some housekeeping.
(It’s pretty easy to prepare for an iOS update, but getting
ready for macOS 10.14 Mojave, which can’t be far behind
iOS 12, requires more effort. Joe Kissell once again has the
advice all Mac users need in Take Control of Upgrading to
Mojave, and the early access version of Scholle McFarland’s
Take Control of Mojave is also now available. In particular,
these books cover Mojave’s changes to APFS, new privacy
protections, major new features, and more. You can get
these books in a bundle with my Take Control of iOS 12
for 35% off.)

Click Continue.
Enter your passcode on your device when prompted.
Back in iTunes, click the device icon which is next to the
media pop-up menu in the upper-left quadrant of the
iTunes window.
From the device’s Summary screen, select This Computer
and Encrypt iPhone Backup and then click Back Up
Now.

Back Up Your Devices
You should be backing up your devices regularly, but if
you’ve fallen out of the habit, now is the time to get back
on the wagon! Historically, the advice here is, if you’re
going to make only one backup, to do it in iTunes. However,
we’ve seen problems with iTunes backups of late, and it’s
clear that Apple isn’t paying much attention to iTunes
these days. So we recommend that you back up to both
iTunes and iCloud so if something goes wrong with one
backup, you’ll have the other. Both are easy, and the only
real downside of either is that you need enough space,
either on your Mac’s drive or in iCloud.
Here’s how to back up your iOS device with iTunes:
Connect your iOS device to your Mac with a Lightningto-USB cable. (Yes, you can do this over Wi-Fi, but if
you need these instructions I’m assuming you haven’t
set that up.)

If you have purchases on your device that aren’t in your
iTunes library, you’re asked if you want to transfer
them. Although this isn’t essential, it’s probably a
good idea to do this.
Note that this process can take a long time, and your device
must remain connected to your Mac until it’s finished.
To back up to iCloud, follow these steps:
Go to Settings > Your Name > iCloud > iCloud Backup.

Open iTunes.

Turn on iCloud Backup if it’s not already enabled.

If you haven’t connected your device in a while, a dialog
will ask if you want to allow your Mac to access the
information on your device.

Tap OK.
Tap Back Up Now.
Although an immediate backup to iCloud does not require
your device to be plugged in, for automatic backups to
occur—which we highly recommend!—your device must
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be connected to power, be on a Wi-Fi network, and have its
screen locked.
There’s only one good excuse not to back up to iCloud
regularly, which is not having enough iCloud space to
complete the backup. Apple gives all iCloud users 5 GB
of free space, but given the capacities of modern-day iOS
devices, 5 GB often won’t be enough, especially if you use
iCloud Drive. It might be possible to delete enough files
to make a backup possible, but it’s much more likely that
you’ll need to buy more storage in Settings > Your Name
> iCloud > Manage Storage. 50 GB costs $0.99 per month,
200 GB is $2.99 per month, and 2 TB will run you $9.99 per
month.
Ideally, you’ll perform this backup step after the rest of the
tips in this article, just before you update to iOS 12, but if
you haven’t backed up recently, the sooner the better!

Free Up Space
If your device lacks sufficient free space to install iOS 12,
the installer should be able to clear enough space
automatically during the installation by offloading apps
and bringing them back afterward. Nonetheless, it’s worth
spending a few minutes to review what’s taking up space
on your device and clear out any cruft. You’ll want about 2
GB free to install iOS 12 without any fuss.
Fortunately, iOS makes clearing space easy these days.
Go to Settings > General > iPhone Storage. (Or iPad Storage. Or iPod Storage. I hate these device-specific settings
names.) You’ll almost certainly see a list of recommendations that you can trigger with a tap to free up storage
space. iOS also provides a handy chart at the top of the
screen to show what’s eating up space. Apps, music,
movies, and photos are common culprits.

Update Your Apps
If you update your apps manually but haven’t done so for
some time, it’s a good idea to do so now. Keeping your apps
up to date helps avoid security and compatibility issues, and
you don’t want to be updating everything on the same day
as iOS 12’s release because Apple’s servers will undoubtedly
be slammed.
Frankly, so many apps get frequent minor updates that
attempting to manage this process manually is more work
than it’s worth. I highly recommend enabling automatic
updates, which you can do by turning on Updates in
Settings > iTunes & App Store. iOS will start updating apps
automatically, and while you don’t get much control over
when the downloads happen, you can disable the Use
Cellular Data switch in Settings > iTunes & App Store to
ensure they take place only over Wi-Fi. And, of course, if
you know an update is pending and it hasn’t come in yet,
you can kickstart app updates by opening the App Store
app, tapping Updates, and tapping Update All.

The best way to free up space quickly is by deleting unwanted apps, particularly those with a lot of data, like podcast
apps you don’t use anymore. You can do this from the
Home screen, but the iPhone Storage screen lists your apps
in the order of how much space they consume, and tapping
them gives shortcuts for deleting or offloading apps.
Offloading an app gets rid of the app, but keeps its data, so
you can later download the app again and pick up where
you left off.
In Take Control of iOS 12, I have an entire chapter on data
management, including managing space on your device,
handling bandwidth usage, and juggling iCloud storage.

Opt Out of the Beta
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If you’re using the iOS 12 beta, you may think you’re as
prepared as you can be. However, unless you want to stay
on the beta track, which may be more confusing than it’s
worth after the official release, you’ll want to delete the
beta profile so you get regular updates instead of beta
updates. To do so, go to Settings > General > Profile > iOS
12 Beta Software Profile, and tap Remove Profile.

In my experience, the ideal time to hop off the beta
bandwagon is sometime after you install the golden
master, which is often identical to the shipping version of
iOS, but before the official release comes out. That way you
can be relatively sure you’re using the release code without
having to struggle to download the shipping version on
launch day. And you’ll get the inevitable point updates that
follow soon after.
Follow these steps before you install iOS 12, and your
installation should go smoothly. And if it doesn’t, you’ll
have no problem erasing your device and restoring from
your backup.

By Josh Centers

Here’s

Popular Mac App Store Utility
Turned Out to Be Spyware

a bit of disturbing news: the top-grossing
utility app in the Mac App Store was
stealing users’ Web browsing histories. The app, Adware
Doctor, managed to sneak past not only Apple’s app
review process but also macOS’s sandboxing protections to
steal and upload browser histories from Chrome, Firefox,

and Safari to servers in China. To add insult to injury, the
developers charged $4.99 for the app, which promised to
“keep your Mac safe.” Apple has pulled Adware Doctor
from the Mac App Store, but if you encounter it on a Mac,
delete it with prejudice.

By Josh Centers

TipBITS: How to Move Your Evernote Notes
to Apple’s Notes

Evernote

is in trouble. In the last month,
the company has lost its CTO,
CFO, CPO, and HR head, and it may soon be seeking more
funding. An anonymous tipster told TechCrunch that the
company is in a “death spiral.” If you’re concerned about
the future of the company and what might happen to your
data stored on Evernote’s servers, now might be a great

time to export your notes. The good news is that the
macOS version of Apple’s Notes app can import them.
To export your Evernote notes, follow these steps:
Open the Evernote Mac app.
Click the All Notes category in the sidebar.
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Choose Edit > Select All.

Click Save.
You’re left with a .enex file, which other popular note-taking
apps, such as Bear and OneNote, can import (if you’re
looking for an Evernote replacement, it’s worth reading
“Your Favorite Mac Personal Information Managers,” 18
January 2016). But as long as you’re running OS X 10.11.4
El Capitan or later, you have an app already on your Mac
that can also import .enex files: Apple’s bundled Notes
app. To do that:
Open Notes.
Choose File > Import to Notes.

Choose File > Export Notes.

Select the .enex file that you exported from Evernote.

In the Save dialog, name the export file and choose a
directory for it. Stick with the default Evernote XML
Format in the Format pop-up menu.

When asked if you want to continue, click Import Notes.
Your imported notes end up in a special Imported Notes
folder, so they won’t clutter up any existing items you have
in Notes. Overall, the notes transfer over from Evernote
nicely: formatting, checklists, bullet points, and attachments all survive the import. Notes can even search for text
in scanned images using OCR, though maybe not as well
as Evernote can. That said, readers have reported performance problems in Notes with very large imports.
In any case, Notes isn’t going anywhere, so your notes will
be safely accessible for the foreseeable future. If you end up
moving away from Evernote, let us know in the comments
what app you decide to use and why.

By Michael E. Cohen

The Big News about macOS 10.14 Mojave
Is Dark

More

than an hour and a half into the WWDC
keynote, Apple’s senior vice president of
Software Engineering, Craig Federighi, gave an overview
of the next macOS that described an operating system that
was once again more a matter of buff and polish than new
features. In fact, he described the changes in macOS 10.14,
called Mojave (pronounced mo-HA-vay) after the southern
California desert known for its Joshua trees and aridity, as
consisting largely of “pro features that everyone will enjoy.”

In fact, that seems to be the case: Mojave doesn’t look much
different than previous versions of macOS—that is, until
you enable its marquee feature, Dark Mode. This affects the
appearance of the menu bar, menus, and Desktop, as well
as of any apps that have made use of the new Dark Mode
API provided by Mojave. Enable Dark Mode and the difference between macOS 10.13 and 10.14 is as plain as night
and day.
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Dark Mode and Friend
Indeed, Dark Mode is one of those features that pro users
of photo- and video-editing apps have long requested, and
one that many non-pro users might want to use. Apple
describes the feature as a way of reducing distractions and
helping users focus on the task at hand.
It uses a darker color palette for all windows, views,
menus, and controls, and it employs vibrancy adjustments
to provide contrast between foreground and background
elements. Until developers hop aboard the Dark Mode
bandwagon, however, apps that will include Dark Mode
designs when Mojave ships will likely be mostly the Mac
mainstays such as Mail, Messages, Maps, Calendar, and
Photos. How fast developers adopt Dark Mode depends
on how easy it is to incorporate the Dark Mode API into
existing apps. Furthermore, it remains to be seen, literally,
how Dark Mode will work with multiple desktops in
Mission Control, and how distracting a screen will look
when containing windows from both Dark Mode-savvy
and older apps.

Apple’s site provides a quick way to compare Dark Mode with the
more familiar look of macOS.
Along with Dark Mode comes a cosmetic companion:
Dynamic Desktops. These are Desktop backgrounds that
change appearance depending on the time of day—for example, a desert scene in daylight that gradually transitions
to the same scene at night. So far, it seems that Apple will
be the sole provider of these animations, and users won’t
have to worry about their cat wallpaper pictures becoming
dark and strange after the sun goes down.

Stacks and Other Finder
Enhancements
Another change users may appreciate is the new Finder
stacks capability (not to be confused with the Dock’s
stacks). Users who have files scattered around the Desktop
can use this feature to organize those icons by file type,
date, tag, and other criteria into neatly arranged stacks
that, when clicked, expand across the Desktop to show

their contents. Users can also “scrub” the pointer across a
stack to reveal and access individual items in it one by one.
While some might find the Desktop-tidying effect of stacks
a quick and pleasant way to clean things up, others who
rely upon visual memory to find commonly used items
may find the command much less useful, and, in fact,
counter-productive to use.
More generally useful may be Mojave’s replacement for the
Finder’s Cover Flow view, now called Gallery View. The
view seems optimized for navigating folders of graphics
by presenting the contents with an expanded view of the
current item filling most of the Finder window. A row of
thumbnails below it represents other items in the folder,
and a preview pane to the right provides complete file
metadata information, similar to Get Info. The view also
offers a collection of Quick Actions for you to modify the
selected file without opening an app. For example, an image
file might have actions for rotating it, marking it up, or
converting it to another image format. You aren’t limited to
Apple’s set of Quick Actions, as you can create Automator
tasks to perform Quick Actions as well.

Quick Look has also been enhanced to allow you to perform actions on many types of files, such as markup, image
rotation, and file sharing. The actions provided in Quick
Look vary depending on the type of file you are viewing.

Take Your Best (Screen) Shot
Apple has significantly enhanced its native screenshot
capabilities. Now when you press the screen capture
shortcut, you get a palette of different screenshot tools.
You then click to choose whether to capture the screen, a
window, or a selection—or to record a movie of your
actions. With the last, you can record the whole screen or a
selected portion. You can specify a custom destination for
your screenshot or leave it in a thumbnail on the Desktop
where you can immediately perform actions on it, such as
marking it up, sharing it, cropping it, or deleting it if it isn’t
what you intended.
Related to screenshots is Continuity Camera. This lets you
use an iOS device’s camera with Mac apps. For example,
you can shoot a photo of a receipt on your iPhone and have
it appear—straightened and ready to use—on your Mac
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Desktop as a PDF, or you can choose Insert Photo from the
Mac version of Pages and then take a photo with your iPad
to supply the photo. Certain Mac apps will come with the
Continuity Camera capability built-in, including the iWork
apps, Mail, and Notes.

iOS Crossovers
Federighi posed the question “Is Apple combining macOS
and iOS?” and immediately answered it with a resounding “No!” But that doesn’t mean that the two operating
systems won’t be connected in new and interesting ways.
Continuity Camera, described just above, is one of those
ways. Another is the Group FaceTime call capabilities that
both iOS 12 and Mojave offer: with it, a FaceTime chat can
include as many as 32 participants. In a group FaceTime
chat, the app smartly highlights the participants who are
currently speaking—a virtual Thanksgiving dinner in the
U.S. this autumn might be a perfect venue for taxing that
capability!
Apple is also working on making it easier for developers
to design apps that can work on both macOS and iOS.
The plan is to migrate some of iOS’s UIKit framework to
macOS so that, say, a finger gesture in iOS can be seen on
the Mac as a trackpad gesture. This year, Apple is testing
this strategy out on their own apps: four iOS apps —News,
Home, Voice Memos, and Stocks — have undergone the
sea change to make them into Mac apps as well. Once
Apple proves and refines the strategy, it plans to make the
necessary frameworks available to developers in 2019.

A Grab Bag of Assorted Changes

Developer Stuff
One user-facing feature of interest to developers will be the
revised Mac App Store, which offers better discoverability
and highlighting of apps, and the capability of asking for
ratings and reviews from within an app (a feature this
writer hopes will seldom be invoked). Apple, however,
remained silent in the keynote about many features for
which developers have long clamored, such as the ability
to offer paid upgrades.
Other features are more invisible to users, but of great
interest to developers. Among them:
A new Network framework to make it easier to establish
various types of network connections.
Create ML, a new machine-learning technology. This
will likely be used with the following feature…
A new Natural Language framework that can analyze
natural language text and deduce appropriate
language-specific metadata.
A more powerful Metal, the graphics API that drives
most of the computational graphics in macOS.
So central is Metal to Apple’s future, in fact, that it is deprecating both OpenGL and OpenCL in Mojave and is restricting Mojave to Macs that can use Metal: that is, Macs
released in mid-2012
or later. Otherwise, unless you have an old Mac Pro that
has been upgraded to use a Metal-compatible GPU, you
won’t be visiting the high desert anytime soon if your Mac
was made prior to 2012.

Lots of little changes and improvements are coming out of
the shade into the bright light of the Mojave sun as well:
Mail in Mojave sports an Emoji button that will make
it easier to add colorful glyphs, and the app also can
suggest where to file a message when you select it in
your Inbox.
Siri is learning more—Apple touts food, celebrities, and
motorsports as some of the domains about which Siri
is getting educated. Also, the digital assistant gains
more capabilities: Siri in Mojave can help you find
saved passwords and control HomeKit devices.
Safari in Mojave can now show favicons in your open
tabs.
New privacy protections have been implemented, such
as automatic strong passwords in Safari, intelligent
tracking prevention that keeps websites from tracking
you easily, and better device and data controls so that
third-party apps must ask permission to use your
camera, microphone, and stored Messages and Mail
data.

Bottom Line
Mojave is mostly an evolutionary update to macOS.
Nothing in it is particularly surprising, but most of what
it offers will be welcome to a wide range of users. Apple
seems focused on refining and enhancing macOS right
now, rather than completely rebuilding it, and most of us
think that’s a good thing.
One final caveat: even if you can get your hands on the
developer release of Mojave that Apple released today, we
strongly recommend you resist the temptation to install it
on any Mac that you need to use for anything other than
experimentation. Did we say “strongly recommend”? We
meant “will laugh callously at your sorrow if” you do such
a foolish thing.
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Software Review
PhotoBulk
By Frank Petrie

I

have many friends) who take thousands upon thousands
of photos. As a result they have all the best hardware
and software to pursue their passion.
But suppose your like me. I only take pictures if something
tickles my eyes or brain. I’m not one to chronicle my
adventures or events. But even with a meager 1,000+ snaps,
I still would like to manage them.
This requires in some instances bulk operations. It could be
naming photos from a specific event and numbering them
sequentially. Or it could be that I want to post some photos
online. But I don’t want just anyone using them, so I’d like
to place a watermark on all of them.
Now batch processing is included in your high-end
photography software but Photos is all I really require.
So, how do I go about this having to do this manually and
driving myself mad?
PhotoBulk] (https://www.eltima.com/bulk-image-editor.
html) is a basic bulk image editor designed for macOS. It
allows its users to place different kinds of watermarks onto
the images, resize and optimize them in batch. This tool
will also be handy for those who look for a convenient way
to rename or convert images in large quantities at once.
As you can tell from the graphic, there is for no learning
curve. Everything is laid out as simple as could be.
Let’s start with the watermarking. If you choose to use text,
you can customize the font, size, and color. You also have
the option of underlining your text. You can also adjust
opacity position.
You resize your images uniformly by height, width,
percentage, and so on. You can choose a particular format:
JPEG, PNG, GIF, BMP, and TIFF. You can also adjust the

quality of the image by percentage or choose to retain the
original quality. You also have the ability to adjust the
optimization of your photos — reduces file size, doesn’t
deteriorate the image. Higher level of optimization may
take more time.
Next, you customize your metadata. You can keep all of
it or delete it entirely. Your choices of metadata are: GPS
Data, Camera Info, and Copyright/Contact Info.
Finally, you can rename your photos and set up a numbering
scheme (i.e., 0000, 000, 00, 0), either as a suffix or prefix.
This app is so easy to use. As I said, there isn’t even a
learning curve. It performs admirably. All you do is launch
it and look it over for several minutes. You have now
mastered it. The developers have created an app that is
extremely productive, robust, and pragmatic..
PhotoBulk costs USD $9.99. And if batch watermarking is
all that you really require, PhotoBulk Lite is available for
free at the Mac App Store. Requirements: OS X 10.10 or
later, 64-bit processor.

Apple Updates
iTunes 12.8 for Mac
Sep 12, 2018
System Requirements
– OS X version 10.10.5 or later
iTunes now supports AirPlay 2 multi-room audio and
HomePod stereo pairs.
Use the AirPlay menu to easily group HomePod, Apple
TV, and other AirPlay 2-enabled speakers and control what
plays next.
Songs from the Apple Music catalog cannot be burned to a
CD.
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